Mailinglist Archive: opensuse (1606 mails)

< Previous Next >
Re: [opensuse] Can't boot 10.3 after 11.0 install - explanation for Patrick
  • From: Bob S <911@xxxxxxxxxxx>
  • Date: Wed, 3 Sep 2008 21:21:06 -0400
  • Message-id: <200809032121.06490.911@xxxxxxxxxxx>
On Tuesday 02 September 2008 21:56:34 Patrick Shanahan wrote:
* Bob S <911@xxxxxxxxxxx> [01-01-70 11:34]:
On Tuesday 02 September 2008 18:25:36 Patrick Shanahan wrote:
* Bob S <911@xxxxxxxxxxx> [09-02-08 17:46]:
During the boot up process it fails and dumps me into maintenance
mode. It says "FSCK failed for at least one filesystem. (not /)Then
to do it manually and reboot.

I shutdown and then did an fsck on the entire filesystem. (All
three drives) Didn't help. Now the funny thing is that 10.2 and the
new 11.0 boot OK and every fstab is exactly the same.

you don't reall mean this? all three fstabs are the same? They
cannot be, addressing three different systems!

Hi Patrick, Thanks for replying.

Yes, I do. That way I could access any file on any system. Worked just
fine on 10.2 and 10.3. If I can't cure it I will try modifying the fstab
files.

More explanation is necessary. You cannot have all three systems
using the same root and the same /var, and .... And you said that you
did not share /var....

Thus the three fstabs *must* be different. Please explain

Hi Patrick,

No, they are all the same. Every mountable partition is mounted in each OS.
Of course they are named differently. e.g. I always make separate partitions
for /home /var and /tmp. When the partitioner asks for a mount point you
cannot use the same one as another existing one. So instead of / I call it
/11.0 and instead of /var I call it /var11.0 etc. etc.

So, when I boot 10.2 (or 11.0) all of the mounted partitions, including the
other os's will show up in the file tree, including /11.0, /10.2 /10.3
/home11.0, /home10.2 /home 10.3 /var11.0, /var10.2 /var10.3 etc etc. Thusly,
all the fstab's will be the same. This worked fine for 10.2 and 10.3 installed
side by side. Whatever os was booted seemed to find it's own partitions to
work with and ignored the others.Same as /workspace, /datastorage, and /backup
which are on the first disk and can be accessed from the other two os's and
disks.Can't tell you why or how this works. But it did with 10.2 and 10.3, and
now it works with 10.2 and 11.0.

Am I violating some rule here? If I am and this is not supposed to work please
let me know. Do you run more than one version of openSUSE? If so, how do you
handle duplicate file names within the different versions that the installer
allows.

Another thing, is it possible to paginate the boot screen? I seem to remember
way back in the Win3.11 days you could add a -p or something like that to get
a screenfulj at a time.If I could do that I might be able to see where the
trouble is.

Bob S
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups