Mailinglist Archive: opensuse (2778 mails)

< Previous Next >
[opensuse] kdesu bug when path includes spaces (openSUSE 11.0 Beta3 KDE4 LiveCD x86_64)
  • From: "Michael Mientus" <michael.mientus@xxxxxxxxx>
  • Date: Sun, 25 May 2008 23:39:31 -0500
  • Message-id: <cd2486570805252139n5f187d54p7d73b819f115d2cc@xxxxxxxxxxxxxx>
Hi,

I have a directory (/home/michael/openSuSE x64 Packages/) with a
package (truecrypt-5.1a-0.x86_64.rpm) in it. When I click on the RPM
in Dolphin, KDE su launches with the following command "/sbin/yast2
--install /home/michael/openSuSE x64
Packages/truecrypt-5.1a-0.x86_64.rpm". After I enter my root password,
I get three separate errors: 1) Package
Packages/truecrypt-5.1a-0.x86_64.rpm was not found on the medium. 2)
Package x64 was not found on the medium. 3) Package
/home/michael/openSuSE was not found on the medium. After the three
errors, YaST quits.

The errors are obviously related to the spaces. But I am not sure if
this is openSuSE's problem or KDE's problem. I am inclined to believe
that the error lies with openSuSE because kdesu has no way of knowing
the last part is a path. I think there is a bug in one of the openSuSE
scripts.

Should I create a bug for this at bugzilla.novell.com?

Also, I could use some help picking a better description since this is
not really a kdesu bug in my opinion. Can anyone tell me what those
"scripts" are called?

Thanks in advance.

Mike
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >