Mailinglist Archive: opensuse (2348 mails)

< Previous Next >
[opensuse] Cups IPP interface w/ Mac OS X: Get-Printer-Attributes client-error-not-found
  • From: "Chris Worley" <worleys@xxxxxxxxx>
  • Date: Thu, 3 Apr 2008 22:38:21 -0600
  • Message-id: <f3177b9e0804032138q13154161pf2c0b58db13471f7@xxxxxxxxxxxxxx>
My printers work correctly locally.

I'm trying to get them to work over a network w/ MAC OSX.

I've got CUPS setup for all users with no limit on the network access.

From the Mac, I can point a browser to port 631 on the Linux side and
see the printers.

When I try to print, The access_log for CUPS prints:

192.168.0.11 - - [03/Apr/2008:22:36:35 -0600] "POST /MFC3360C
HTTP/1.1" 200 292 Get-Printer-Attributes client-error-not-found

The CUPS error_log periodically prints (for each of my printer definitions):

E [03/Apr/2008:22:36:36 -0600] SLPReg of "MFC3360C" failed with status -20!
E [03/Apr/2008:22:36:37 -0600] SLPReg of "All-in-1" failed with status -20!
E [03/Apr/2008:22:36:38 -0600] SLPReg of "BRFAX" failed with status -20!
E [03/Apr/2008:22:36:44 -0600] SLPReg of "HP" failed with status -20!

... but this happens whether or not the MAC is trying to print, and
local printing works properly.

On the MAC side, when I try to print something... it waits for awhile
then says the printer is paused.

This is on OpenSuSE 10.2.

Any ideas?

Thanks,

Chris
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups