Mailinglist Archive: opensuse (2348 mails)

< Previous Next >
Re: [opensuse] Zypper Dup Failed : unpacking of archive failed: cpio: Bad magic
  • From: "Dominique Leuenberger" <Dominique.Leuenberger@xxxxxxxxxxxxx>
  • Date: Thu, 03 Apr 2008 12:38:09 +0200
  • Message-id: <47F4CFB0.2554.0029.1@xxxxxxxxxxxxx>
On 4/3/2008 at 12:17, "Masim "Vavai" Sugianto" <vavai@xxxxxxxxx> wrote:
On Thu, Apr 3, 2008 at 3:40 PM, Dave Plater <davejplater@xxxxxxxxx> wrote:
vavai # zypper in rpm
Reading installed packages...

The following package is going to be upgraded:
rpm


The following NEW package is going to be installed:
perl-base


The following package is going to be REMOVED:
rpm


Overall download size: 2.6 M. After the operation, additional 729.0 K
will be used.
Continue? [YES/no]: y

I'm really wondering what sane user would ever say YES to THIS question... Is
like if the sustem aks you for permission to selfdestruct... as it's a
question, let's reply with YES?? Sorry.. I would say you had rather some luck
that perl-base failed in first instance... otherwise you'd probably have ended
up with a system without rpm installed on it... tough luck to install anything
else.. even using zypper, as zypper just relies on rpm in the background.

What you can try is to download rpm from the factory repository manually and
install it using rpm -Fhv rpm-4*.rpm

Dominique

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups