Mailinglist Archive: opensuse (2348 mails)

< Previous Next >
Re: [opensuse] New 10.3 install -- firefox for non-root users displays no graphics?
  • From: Sunny <sloncho@xxxxxxxxx>
  • Date: Tue, 1 Apr 2008 18:35:35 -0500
  • Message-id: <e7eeb230804011635g455038c4w71bb11f3ea4b113c@xxxxxxxxxxxxxx>
On Tue, Apr 1, 2008 at 5:44 PM, David Pierce <dpierce@xxxxxxxx> wrote:

Last week I finished an install of OpenSuSE 10.3 x_64 on a Intel quad core
cpu. The install went smoothly, but there is an odd problem. When I run
firefox as root, everything looks fine. But if I run firefox as a regular
user, the firefox window displays no graphics. Neither firefox's icons
nor any graphics in the main display window appear.

Assuming it was some sort of odd permissions problem (since it works for
root) I turned off AppArmor, but that didn't make any difference. I get
this behavior under both icewm and KDE, but I don't think the window
manager has anything to do with it since I can su root and then run
firefox fine, but when I exit the su and try to run firefox again it has
the problem described above.

Does anyone have any suggestions, I'm really stumped.

Close, firefox, and rename .mozilla/firefox directory in your home
folder to something like .mozilla/firefox.old. Start firefox agan and
see if this helps:

mv ~/.mozilla/firefox ~/.mozilla/firefox.old


Svetoslav Milenov (Sunny)

Even the most advanced equipment in the hands of the ignorant is just
a pile of scrap.
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread