Mailinglist Archive: opensuse (2348 mails)

< Previous Next >
[opensuse] Re: envvar DISPLAY not set on bash invocation fr/sshd
  • From: Linda Walsh <suse@xxxxxxxxx>
  • Date: Tue, 01 Apr 2008 11:22:29 -0700
  • Message-id: <47F27D65.2090802@xxxxxxxxx>
Joachim Schrod wrote:
What's the output of "ssh -v -v fail"?
There should be lines like

debug2: x11_get_proto: /usr/X11R6/bin/xauth list :0.0 . 2>/dev/null
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: channel 0: request x11-req confirm 0
...
Call "xauth info" on `fail' to check that.
----
Arg! SuSE moved the location of 'xauth' out of
RPM "xorg-x11-libs" (v6.8), which one would expect to need if one
wanted to run X programs, ---> into
RPM "xorg-x11" (v7.2). The 'Fail'ing machine doesn't run an X-server. It
is only 'logged into' remotely and has no desktop, so it didn't have an
X server installed.

Sigh.... I guess I have to install the Xserver now, even though
it's on a machine that runs no server. Brilliant!

Oh well...thanks...and now we know why my upgrades are painful --
programs keep getting shuffled around randomly out of one RPM into
another; moved out of 'X11-support files' (x11-libs) in with the
'X-Server files', even though xauth is needed by clients -- not by the
server (i.e. xauth won't run unless the server is already running and
one doesn't need xauth to start the server (AFAIK)).

Thanks very much for the help!

Linda
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References