Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
[opensuse] X server fails partly in KDE4
  • From: "Henk A.M. Weebers" <h.weebers@xxxxxxxxxxxx>
  • Date: Sat, 22 Mar 2008 13:02:44 +0100
  • Message-id: <200803221302.44742.h.weebers@xxxxxxxxxxxx>
Ladies and Gents,
My system consists of an A7N8X-E motherboard, a Radeon 9200SE graphic adapter,
openSUSE 10.3 and KDE3 or KDE4.

I started KDE4 as user in the beta versions. For a month I changes something
in knotify. After restarting KDE4 I get a black screen and some sounds.
Applications seems to have been launched.

Strange enough is the fact that running KDE4.0.2 as root starts the X server
normally. But this was a fresh start.

Searching for error solutions I modified data files to correct errors reported
by kbuildsycoca4. Still there are errors been reported
1. ""fsrestore1" - conversion of "0,0,0,0" to QRect failed" I cannot find
any solution.
2. Couldn't start knotify from knotify4.desktop: "KDEInit coudn't
start '/usr/bin/knotify4' . $HOME/.kde4/share/config/knotifyrc has been made
identical to the knotifyrc-file for root. But still this is not the solution:
X Error: BadMatch (invlid parameter attributes) 8
Extension: 155 (RENDER)
Minor opcode: 4 (RenderCreatePicture)
Resource id: 0x4e
After that some other errors appear.

.xsession-errors as been attached. Unfortunally kdm.log is not reported for
KDE4.

IMHO there must be someone who can help me.
Regards,
Henk
---------------------
"Dat moet even op een rijtje gezet worden"
/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: user environment variable LANG=nl_NL.UTF-8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale nl_NL.UTF-8 ...
There is no default input method for the current locale.
startkde: Starting up...
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
kdeinit4: preparing to launch /usr/bin/kded4
kdeinit4: preparing to launch /usr/bin/kbuildsycoca4
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib/kde4/libexec/kconf_update
kdeinit4: preparing to launch /usr/bin/kcminit_startup
kdeinit4: preparing to launch /usr/bin/ksmserver
kdeinit4: preparing to launch /usr/bin/kwin
kwin(10415): ""fsrestore1" - conversion of "0,0,0,0" to QRect failed"
kdeinit4: preparing to launch /usr/bin/krunner
kdeinit4: preparing to launch /usr/bin/knotify4
kwin(10415): Couldn't start knotify from knotify4.desktop: "KDEInit kon
'/usr/bin/knotify4' niet opstarten."

X Error: BadMatch (invalid parameter attributes) 8
Extension: 155 (RENDER)
Minor opcode: 4 (RenderCreatePicture)
Resource id: 0x4e
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
kdeinit4: preparing to launch /usr/bin/plasma
X Error: BadMatch (invalid parameter attributes) 8
Extension: 155 (RENDER)
Minor opcode: 4 (RenderCreatePicture)
Resource id: 0x4e
Object::connect: No such signal Plasma::Icon::activated()
Object::connect: No such slot Tasks::launchActivated()
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
kdeinit4: preparing to launch
kdeinit4: preparing to launch
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
QPainter::begin: Cannot paint on a null pixmap
kwin: X Error (error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2],
resource: 0x1600032)
QPainter::begin: Cannot paint on a null pixmap
kdeinit4: preparing to launch /usr/bin/kaccess
kwin: X Error (error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2],
resource: 0x160002f)
kdeinit4: preparing to launch /usr/bin/kmixctrl
kdeinit4: preparing to launch /usr/bin/ktip
kdeinit4: preparing to launch /opt/kde3/bin/appspreloader.sh
kdeinit4: preparing to launch /opt/kde3/bin/runupdater
(Soprano::PluginManager) loading all plugins
kdeinit4: preparing to launch /usr/bin/beagled
kdeinit4: preparing to launch /usr/bin/klipper
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/nquadparser.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_nquadparser"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_nquadparser.so"
(Soprano::PluginManager) found parser plugin "nquads"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/nquadserializer.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_nquadserializer"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_nquadserializer.so"
(Soprano::PluginManager) found serializer plugin "nquads"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/raptorparser.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_raptorparser"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_raptorparser.so"
(Soprano::PluginManager) found parser plugin "raptor"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/raptorserializer.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_raptorserializer"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_raptorserializer.so"
(Soprano::PluginManager) found serializer plugin "raptor"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/redlandbackend.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_redlandbackend"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_redlandbackend.so"
(Soprano::PluginManager) found backend plugin "redland"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/nquadparser.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_nquadparser"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_nquadparser.so"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/nquadserializer.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_nquadserializer"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_nquadserializer.so"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/raptorparser.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_raptorparser"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_raptorparser.so"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/raptorserializer.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_raptorserializer"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_raptorserializer.so"
(Soprano::PluginManager) found plugin file
"/usr/share/soprano/plugins/redlandbackend.desktop"
(Soprano::PluginManager) plugin has proper version. Trying to load lib:
"libsoprano_redlandbackend"
(Soprano::PluginManager) loaded something from
"/usr/lib/soprano/libsoprano_redlandbackend.so"
kdeinit4: preparing to launch /usr/bin/kmix
kdeinit4: preparing to launch /opt/kde3/bin/kinternet
kdeinit4: preparing to launch /opt/kde3/bin/knetworkmanager
kbuildsycoca running...
DCOP Cleaning up dead connections.
kdeinit4: preparing to launch /opt/kde3/bin/kpowersave
kdeinit4: preparing to launch /opt/kde3/bin/kxkb
kdeinit4: preparing to launch /opt/kde3/bin/opensuseupdater-kde
klauncher(10356) KRunMX1::expandEscapedMacro: -miniicon isn't supported anymore
(service "SUSE Hardwareprogramma/KDE3" )

kdeinit4: preparing to launch /opt/kde3/bin/suseplugger
kwin: X Error (error: <unknown>[DAMAGE+0], request: XDamageDestroy[DAMAGE+2],
resource: 0x160004c)
ktip: Fatal IO error: client killed
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
kwin: Fatal IO error: client killed
klauncher: Exiting on signal 1
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
kded: Fatal IO error: client killed
kdeinit: Fatal IO error: client killed
klauncher: Exiting on signal 15
klauncher: Fatal IO error: client killed
knotify: Fatal IO error: client killed
kded4: Fatal IO error: client killed
KWrited - luistert op apparaat /dev/pts/0
ksmserver: Fatal IO error: client killed
< Previous Next >
Follow Ups