Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] / as a LV
  • From: Moby <moby@xxxxxxxxxxxxxx>
  • Date: Tue, 18 Mar 2008 10:29:32 -0500
  • Message-id: <47DFDFDC.7010701@xxxxxxxxxxxxxx>

Pete Connolly wrote:
On Tuesday 18 March 2008 14:16:24 LDB wrote:
LDB wrote:
LDB wrote:
Ciro Iriarte wrote:
2008/3/17, LDB <thesource@xxxxxxxxxxx>:
That is what I thought, but I had an old server using an older
MegaRAID and it would not activate the VG hence it would not
mount the root volume. I had to resort to non-LVM for the root

When I booted it into rescue mode, it was fine.


What do you mean by "would not activate the VG"?, If it can boot from
the same array using regular partitions, LVM should work. At home I
have the root on top of LVM on top of MD raid1 running Opensuse
10.3@x86_64. At the office I have root on top of LVM on top of HP
SmartArray (cciss driver) running SLES9SP3@{x86_64,i386} and
everything works fine. Did you install with / on a LV or tried some
kind of migration later?

Agreed, but after the autoyast installation process and during the
1st boot, it stops and spews the the following ...

Attempting manual resume
Waiting for device /dev/rootvg/root to appear: ..................
not found -- exiting to /bin/sh

but then when I boot into rescue mode it mounts just fine ...

Any ideas??

Scrutinizing even more I am discovering that it is seemingly not
loading the cciss driver on the 1st reboot after the OS installation.
Which does not make sense, since that is what was used to install
the OS in the first place.

Scratch that last assessment it does load it ...


You might need to recreate your initrd using the mkinitrd command and using the 'feature' option (-f). From the help page...

-f "feature list" Features to be enabled when generating initrd.
Available features are:
iscsi, md, mpath, lvm, lvm2, evms

This is just to ensure that right lvm2 modules are included in the initial ram disk, plus the linuxrc has the required vgchange commands to activate the root lvm.

I personally can't see a good reason to use lvms for root. The resizing ability is nice but I rarely resize root, just the seperate data lvms.


I had exactly the same problem - root cause was that Grub did not get installed to the MBR of /dev/cciss/c0d0. Fix was to boot into rescue mode, mount the root (/dev/system ... however your LVs are setup). Then mount /dev and /proc into the newly mounted root, chroot to the /dev/system/... root, and then re-run grub install to install into the MBR of /dev/cciss/c0d0.
Worked like a charm here, hope it works for you as well.


They that can give up essential liberty to obtain a little temporary safety
deserve neither liberty nor safety. -- Benjamin Franklin

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups