Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] Starting a Java application
  • From: Anders Johansson <ajh@xxxxxxxxxx>
  • Date: Tue, 18 Mar 2008 00:21:41 +0100
  • Message-id: <47DEFD05.9010403@xxxxxxxxxx>
Stan Goodman wrote:
On Tuesday 18 March 2008 00:17:32 Anders Johansson wrote:
Stan Goodman wrote:
Clicking on the icon brings up the exasperating announcement
that: "KDEInit cannot
launch '/usr/lib64/jvm/java-1.5.0-sun-1.5.0_update14/jre/bin/javaw'".

That is indeed where Java lives, but there is no file called "javaw"
in that directory. Even more surprising, <find -name "javaw"> doesn't
find anything on the system. (I ran that as root, from /).

What does one do?
It's a typo. Just delete the w. It should be .../jre/bin/java

Anders

I must not have been clear. There is noplace where "javaw" is visible
except in the error message. I don't know that it is a typo; "javaw" is a
normal Java executable. I don't know why there is none on my system.

It is not normal on a linux system

The typo is in $HOME/Desktop/Genealogy\ J.desktop

In that file you have a line that says

Exec=/usr/lib/jvm/java-1.6.0.u4-sun-1.6.0.u4/jre/bin/javaw -Xmx512m
-Xms32m -jar run.jar

Edit that to remove the w from javaw, and it will work. I tried it
myself here, and it does work

Anders
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >