Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] /dev/md0 borked, can't mdadm --stop it, can't swapon/dev/md0
  • From: "Antryg Revok" <antrygrevok@xxxxxxxxxxxxx>
  • Date: Sat, 15 Mar 2008 01:31:38 -0400
  • Message-id: <N1N-LkpxfYWQOR@xxxxxxxxxxxxx>
Maybe is something hasn't yet been implemented. About 1.5 years ago you
could not have two swap partitions and suspend; now you can. You could not
have /boot on raid, now you can. Perhaps raid on swap will allow
suspending in the future. Not now.

- --
Cheers,
Carlos E. R.


Ah, to the best of my knowledge, /boot on raid-1 worked fine, for years. . .

( because the only difference between raid-1 partition and normal
( ext3, reiserfs, whatever )
partition was the signature-thingy at the end of it:

just set lilo to boot from one of the partitions /underlying/ raid-1, and it'd
do fine.
For redundancy, do it for each of the raid-1 components, and install lilo on
every single device's mbr, as well as some other device, like a diskette.

I suspect that grub on raid-1 would have required
boot from /dev/sda3 ( or some such )
alternate boot from /dev/sdb3 ( redundancy is a /good/ thing )
root=/dev/md2 ( raid-1 )
. . then it'd have worked fine. . .

The only problem with that was when the death of a device caused the BIOS to
re-name all the devices: /then/ you couldn't boot ( using the lilo method --
been there ). . .

. . . been messing with Linux for 12 years . . .

( & been begging suse to nice-ify all system-level cron-type stuff for a damn
decade!
What's with the DoS periodically implemented with the zypp/zypp-wrapper
checking for new updates thingy?!?? Why not nice it?? idiocy! )

Cheers,

-Antryg
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages