Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
[opensuse] agetty crashing
  • From: Frank Steiner <fsteiner-mail1@xxxxxxxxxxxxxx>
  • Date: Wed, 12 Mar 2008 16:00:41 +0100
  • Message-id: <47D7F019.1090501@xxxxxxxxxxxxxx>
Hi,

I've some servers with ipmi cards and I run a agetty to provide a login
prompt via ipmi. The servers are running SuSE 10.1 and/or SLES 10 SP1.

The agetty process is "agetty -L 115200 ttyS1 vt102".It starts via inittab (or from the shell), and I can connect with ipmi to the host and get indeed a login prompt and can login. But any "ls -la" already stops
after some lines with a bunch of weird characters:

naur /root# ls
.Safedelrc .kde Desktop
.Xauthority .login InstallShield
.adobe .logout TSM.PWD
.bash_history .macromedia Update9690
.bashrc .mozilla a
.config .mplayer bin
.cshrc .opera bla
.esd_auth .qt diskless-backup
.exrc .rpmmacros dsmerror.log
.fonts.cache-2 .safedelete.lock failure.txt
.fvwm .safedelete.log fdisk.naur
.gamtrc
����S�ٕ�}������ɽ�}�������ѥ��m�m�����m�m���m�m�ѵ��m������m�m�ᕵ����m����m�m�������m�m��
naur /root#
But I can continue typing some commands... At the latest after 2 or 3 ls, the agetty process dies. When I start from the shell, it dies, too, but when I start it with strace from the shell, I still get the weird characters
at every ls, but agetty stays alive all the time.

I switched the IRQs/IO for com1 and 2 in the bios, also just changed the irq/IO
for com2, and also switched the "remote ipmi access" in the bios from com2
to com1 - always the same problem.

I also tried mgetty instead of agetty, crashing also without any helpful
message in the log file (even not with -x 5).

Showing all the boot messages with "append = console=ttyS1,115200" works
fine and shows me the whole boot process without any weirds chars. It's
only agetty/mgetty that is crashing.

Does anyone have an idea where I can start looking for the error? I've
absolutely no idea :-(

cu,
Frank

--
Dipl.-Inform. Frank Steiner Web: http://www.bio.ifi.lmu.de/~steiner/
Lehrstuhl f. Bioinformatik Mail: http://www.bio.ifi.lmu.de/~steiner/m/
LMU, Amalienstr. 17 Phone: +49 89 2180-4049
80333 Muenchen, Germany Fax: +49 89 2180-99-4049
* Rekursion kann man erst verstehen, wenn man Rekursion verstanden hat. *
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages