Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] reiserfs - No space left on device
  • From: Dave Howorth <dhoworth@xxxxxxxxxxxxxxxxx>
  • Date: Wed, 12 Mar 2008 10:54:40 +0000
  • Message-id: <47D7B670.4010905@xxxxxxxxxxxxxxxxx>
tabris wrote:
Maybe ReiserFS has the same problem XFS does, wherein it can only create
so many inodes if left in the default 32bit mode (in XFS, the
inodenumber is related to where on disc it is physically located. This
causes issues past the 1TB mark, where it starts having to use 64bit
inode numbers)

reiserfs doesn't have inodes.


Sloan wrote:
You're correct, of course - technically speaking, there are no inodes
in reiserfs. But perhaps there is something analogous to that in this
situation.

I'm not aware of anything; please let me know if you know of anything
specific. The limit I am aware of is 2^32 files and I'm several orders
of magnitude away from that.


Don Raboud wrote:
So there is about 5% free space?

df says 3%. I make it 3.6%

It is my understanding that ext3 file systems for example reserve
some space for the root user (5% by default?). Do reiser file
systems do something similar? Can you use that space as root?

I don't believe reiser does that but in any case I also see the problem
as root.


Sloan wrote:
OK, I wasn't paying close enough attention - the OP is running the
kernel from the original install, never updated, so he naturally
didn't get the reiserfs fix mentioned earlier -

http://lists.opensuse.org/opensuse/2007-10/msg03901.html

That's right. I am aware of Ciro's problem that is now solved but I'm
also aware of another similar problem that isn't solved and so far I
don't have enough details to be able to check which problem I have or
whether I have something different again. I built my problem after that
fix was tested but I don't know when or if it went into the default
kernel. So I don't know whether that fix is in the system I'm running.


Sam Clemens wrote:
Sounds like filesystem corruption... like the free-list got lost.

I'm running reiserfsck to eliminate that possibility. So far it says:

reiserfsck --check started at Tue Mar 11 11:50:44 2008
###########
Replaying journal: Done.
Reiserfs journal '/dev/mapper/storage-data' in blocks [18..8211]: 0
transactions replayed
Checking internal tree.. finished
Comparing bitmaps..finished
Checking Semantic tree:
/trembl/xml/releases/2006-05-16/P97842.xml

Two years to go :) No errors in the log so far.


Sam Clemens wrote:
What is the exact diagnostic message?

I posted that earlier, and it's the subject of the thread :)
"No space left on device".

And what is the output of df -H?

The filesystem is offline because of the reiserfsck so I can't run df
now. It previously said something like:

/dev/mapper/storage-data 1.1T 1.1T 40G 97% /data


Cheers, Dave
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >