Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] Opensuse Updater endless Loop - Bad Cups Update?
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Wed, 5 Mar 2008 22:51:57 +0100
  • Message-id: <20080305215156.GA10641@xxxxxxx>
On Wed, Mar 05, 2008 at 09:55:24PM +0100, Marcus Meissner wrote:
On Wed, Mar 05, 2008 at 12:42:42PM -0800, James Bullock wrote:
JP Rosevear wrote:
On Wed, 2008-03-05 at 11:46 -0800, John Andersen wrote:
Today Opensuse Updater indicated there was new fixes (security fixes
for CUPS etc).

I told the updater to install these, and they all went fine, but then
the updater turns
ORANGE and says there is one more recommended upgrade. The additional
recommended
upgrade is for Cups, Gnome Collection of updates version 4996-0.

I don't even have Gmone installed !?!??

Not all the patched packages were GNOME only - cups and cups-autoconfig
being the obvious exception.

Regardless of whether I cancel or go ahead and tell it to install
(which probably fails
because I don't have gnome installed), the updater prompts again for
the same package.

Whats up with this package, and why does updater continually prompt
for packages
I have rejected?

If the update can't install for dependency reasons (I don't have
Gmome, remember?) then
why does the Updater not just TELL ME THIS?

I presume it should, so I'm not sure what is happening here (I have all
the relevant packages here).

-JP

+1 on seeing the CUPS updater loop. I'm running 32 bit OpenSuSE 10.3, with
KDE,
as fully patched as auto-update will deliver. Glad to grab diagnostic info -
just tell me what & where.

FWIW, John, there was some borkage somewhere in the updater / dependency
engine
back with the switch to a new back-end, around 10.1 or so. I think it isn't
quite right yet - perhaps something like vulnerable to ill-formed package
info
vs. rejecting it because it's very sporadic and specific to a particular
package
when it does happen.

Not too long ago amarok was doing the exact same thing. Then that got
happier.

I will check it out.

Todays cups update and the GNOME update obviously conflict somehow. (Perhaps
because the GNOME update also has "cups" as patchname :()

It would be very nice if people seeing this could generate a solver testcase
and put it into Bugzilla.

(with yast2 menu entry, or zypper up --debug-solver )

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >