Mailinglist Archive: opensuse (3354 mails)

< Previous Next >
[opensuse] Can not enable DRI for ATI x1400 PCIe
  • From: Valentin Sawadski <valentin.sawadski@xxxxxx>
  • Date: Sat, 31 Mar 2007 13:06:19 +0200
  • Message-id: <200703311306.19976.valentin.sawadski@xxxxxx>
Hello everybody,

I'll bet this is a frequent question but I've been trying to solve my problem 
for 5 hours now, without any luck.

In short, I can not enable DRI for my ATI x1400 PCIe. The Xorg log shows only 
the following errors:

(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
(**) fglrx(0): ATI GART size: 128 MB
(EE) fglrx(0): [pcie] Failed to gather memory of size 131072Kb for PCIe. Error 
(-1000)
[...]
(EE) fglrx(0): GART is not initialized, disabling DRI
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *

I've found many people having this error but most of them could solve it by 
disabling composite, which I also did, but it seems that this is not the 
source of the error in my case. In adittion "lsmod | grep fglrx" shows that 
fglrx and agpgart is installed properly. Oh and I also tried 
setting "UseInternalAGPGART" to both, yes and no, but It always had the same 
effect.

Does anyone have an idea what hinders ATI GART from gathering the memory it 
wants?

Thanks in advance,
Valentin S.
-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages