Mailinglist Archive: opensuse (3354 mails)

< Previous Next >
[opensuse] RE: [opensuse-amd64] SuSe 10.0/64 4Gb memory problem
  • From: "James D. Parra" <Jamesp@xxxxxxxxxxxxxxxx>
  • Date: Mon, 19 Mar 2007 11:43:39 -0700
  • Message-id: <531F1E080638384C9623B00D71AA546D028FDE67@xxxxxxxxxxxxxxxxxxxxxxxxx>
"Joachim Deguara" <joachim.deguara@xxxxxxx> wrote:

> James D. Parra wrote:
> > Hello,
> > 
> > Installed 4GB of physical memory, however only 3GB appear;
> > 
> > # cat /proc/meminfo
> > MemTotal:      3342628 kB
> 
> It sounds like you need to go into the BIOS and ask for "Memwhole
> remapping" and set it to "Software".  This happens because PCI takes the
> address space from 3-4GB (staying under the 32bit boundary) and maps
> over where memory may be so we want the BIOS to map that memory elsewhere.


(disclaimer: I work for AMD in the CPU architecture team)

Remapping in the BIOS is possible with all current AMD parts:
  --  First off, some BIOSes have bugs, so test it out before just using it!

  --  If this is a pre-rev-E part (C0 or CG), then you can perform
      "Software" remapping, but it slows down memory access a bit
      on Opteron systems.

  --  If this is a Rev E or later part, then you can perform "Hardware"
      remapping as well, which has no performance cost.

I'd recommend using the "Hardware" method if you have a Rev E or later
Opteron part.
~~~~~~~

Thank you for your responses. I used 'Hardware' for the Memwhole remapping.

What anomalies might I expect if using 'Hardware' is not the right choice?

Again, many thanks.

~James
-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages