Mailinglist Archive: opensuse (3182 mails)

< Previous Next >
Re: [opensuse] YaST partitioner question - mounted disks
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Fri, 16 Mar 2007 00:36:55 +0100 (CET)
  • Message-id: <Pine.LNX.4.64.0703160025240.13741@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


The Thursday 2007-03-15 at 15:27 -0600, Don Raboud wrote:

> 
> When I fire up YaST -> System -> Partitioner, there is a warning that pops up, 
> essentially saying, among other things,
> 
> NEVER (my emphasis) partition disks that may in any way be in use (mounted, 
> swap, etc) unless you know exactly what you are doing.
> 
> Let's pretend for a moment that this applies to me and I click Yes to 
> continue.  I am curious about the "never" part of this.

:-)

I have often gone ahead too, every time I needed too. However, I try to 
umount every thing possible and even switch to runlevel 1 sometimes.

> 
> In my situation, when I installed 10.2 I created primary swap and root 
> partitions in sdc1 and sdc2.  I created an extended partion (sdc3) and 
> put /home in a logical partition (sdc5).  I intentionally left unallocated 
> space at the initial install.  I would now like to allocate this additional 
> space (sdc6) and mount it at /local.
> 
> Is it safe to do this while the disk is mounted?

It is "possible".

The usual danger is that after you change the partition table, the kernel 
fails reading it (Yast should tell of this particular error when it 
happens), and the kernel keeps using the old table. Depending on the 
particular changes, it may be dangerous or not. However, rebooting solves 
it.

The alternative is using a rescue system for repartitioning.


> I would like to know because I have done this already (several times) :-) and 
> it did not seem to cause any problems - except the last time.  The 
> repartitioning worked, but /local was hosed (interpreted as a read-only file 
> system and no changes could be made - even as root).  
> 
> I checked the disk and it turned out that sdc was failing SMART tests, and I 
> have replaced it.  I have in the past tested the disks occassionally (and 
> will now do so more regularly) and I do not recall this disk ever having 
> failed the smart tests before this (but I am not sure about this).  
> 
> I'm guessing that there was a bad area on the disk, which wasn't accessed as 
> it was in the unallocated space.  Allocating the space led to these problems 
> surfacing.  

Actually, I think the problem arouse while making the new filesystem, not 
while partitioning. In any case, the procedure did not cause the problem, 
just made it to surface.


> (I am getting somewhat paranoid about this because this is the 4th hard drive 
> I have had die on me in roughly the last 18 months. I don't know anyone else 
> in that time who has had even one go bad.)

Same model/manufacturer/supplier/position?

Change any of those parameter. The last one, I'm guessing at vibrations.

Ah! I forgot about the cable: if it is an 80 pin flat ribbon cable, 
replace it. It breaks too easily.

- -- 
Cheers,
       Carlos E. R.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFF+diatTMYHG2NR9URAhLHAJ4itJpOxPi0WGFdsZFqiqePMlCIJQCfdvNW
TqzNaqLjrZ4TvfEazw2zJ5s=
=TaCv
-----END PGP SIGNATURE-----

-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References