Mailinglist Archive: opensuse (2634 mails)

< Previous Next >
Re: [opensuse] Installling a second OS...
  • From: JB <yonaton@xxxxxxxxxxxx>
  • Date: Wed, 28 Feb 2007 22:22:35 -0600
  • Message-id: <200702282222.35383.yonaton@xxxxxxxxxxxx>
On Wednesday 28 February 2007 19:40, Doug McGarrett wrote: 

> On Wednesday 28 February 2007 08:36, JB wrote:
> >   Hiya gang,
> >
> >   SuSE 9.3 is the only OS I have on my system. I have two hdd's though.
> >
> >   I (unfortunately) need to install W98 on the second (blank/empty spare)
> > hdd.
> >
> >   If I open the case and remove the main hdd from the cabling, so that if
> > the system's restarted all the bios will see is one hdd, the 'spare', and
> > install the W98 on that, then once it's all done hook my main hdd back up
> > and start the system, will I be able to just go into YaST and have it
> > find the new OS and add it to fstab?
> >
> >   Is there an easier way than the above?
> >
> >   Thanks for any suggestions.
>
> /snip/
>
> You'll have to reset the drive to be Master, or you won't be able to access
> it.  This is done on all the drives I've seen, by changing little jumper
> blocks. Then, after you install 98 (why not XP, it runs a lot better,
> unless you have really limited CPU and memory--it's about as solid as
> Linux!)

  Yes, the jumper on the back of the hdd itself. I'd have forgotten about that 
too since it's been so long, heh. Thanks.

  eXPee is too eXPensive, and I've had the W98 disk since, well, '98.

> then you will have to reset the drive to Slave, and put the main 
> drive back in, and teach Grub or LILO about the new OS.  It might be a
> little more complicated than that--I had XP as the main OS and SuSE 10.0 as
> the OS on the second drive, and when I had trouble with the second drive,
> and tried to boot off the "C drive" it wouldn't--some of Grub was on the
> second drive, which was not accessible.  I think this is a bug, but I don't
> know.  Anyway, this is the basic protocol.

  What has me worried most is, right now hdb (the spare hdd) is a blank 
(though FAT formatted) drive. I'm worried if I do this and GRUB pukes on me, 
I'll have that 'kstartconfig' error I got a few months ago that wasn't very 
easy to fix except for the help of a couple guys on this list who saved the 
day.
  I think I'll do the simplest thing as another suggested and just do a couple 
things with the BIOS whenever I need to boot into windoze.

-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups
References