Mailinglist Archive: opensuse (2224 mails)

< Previous Next >
Re: [opensuse] LILO/Grub Problem
  • From: Bob S <usr@xxxxxxxxxxx>
  • Date: Sat, 3 Feb 2007 22:37:01 -0500
  • Message-id: <200702032237.01645.usr@xxxxxxxxxxx>
On Saturday 03 February 2007 19:31, Joe Morris (NTM) wrote:
> Bob S wrote:
> > On Saturday 03 February 2007 02:27, Joe Morris (NTM) wrote:
> >> Add this to this file.
> >>
> >> ### Added 10.0 Boot ###
> >> title openSUSE 10.0
> >> root (hd1,2)
> >> kernel (hd1,0)/vmlinuz root=/dev/hdb3 vga=0x31a resume=/dev/hdb2
> >> splash=silent showopts initrd (hd1,0)/initrd
> Sorry, watch the wrapping.

OK. I checked the wrapping. and made your script follow the format of what was

Worked and showed in the menu. Would not boot however with an Error 19.
Linux kernel must be loaded before initrd.
Are we any closer?

> Check out

OK don't know if SuSE uses that Rock LVM. Was all CLI though and when I
installed 10.0 I used the Yast partitioner (all graphic) to set it up.

That URL is not working.

>it appears from these it may be something like
> (hd1,2)/dev/VolGroup00/LogVol00 or something like it. BTW, according to
> the release notes, Yasts partition tool can handle LVMs and might at
> least allow you to get to your data while we get this working. It might
> also help figure out what the root= line should be.

Hmmmm maybe we are past that now?
> Yes, I assumed you would add it after the last entry, but it would only
> change the number for which is the default choice if you do not choose.

Yep that is what I did. and 10.0 comes up as the default.
......<snip more>.................
> Sorry, like I said, not that familiar with lvm. Is it called /dev/hdb3
> like normal, or what is it called? For example, I run a raid 1, so mine
> is /dev/md0.
Yes it is called dev/hdb3 like normal and is designated Linux LVM. FYI There
is another entry further down in the table that is the exact same size and is
identified as /dev/system and is designated LVM2 System.

Back to above. Did a Google on the Error19 in grub and came up with the same
kernel must be loaded before initrd message. Got one promising hit but alas
is in french, which I cannot undedrstand. Maybe jdd could interpret for us.

Hope we're closer.

Bob S
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups