Mailinglist Archive: opensuse (2224 mails)

< Previous Next >
Re: [opensuse] LILO/Grub Problem
  • From: "Joe Morris (NTM)" <Joe_Morris@xxxxxxx>
  • Date: Sat, 03 Feb 2007 15:27:42 +0800
  • Message-id: <45C4396E.205@xxxxxxx>
Bob S wrote:
> Did not touch the hdb (10.0) drive
Good, there is hope.
>> Having the 10.2 files for the above wouldn't hurt either.
>>
>
> OK, some of what you requested to assist me:
> --------------------------------------------------------------------------------------
> (10.2 fstab)
>
> /dev/sda1 / ext3 acl,user_xattr 1 1
> /dev/sda5 /home ext3 acl,user_xattr 1 2
> /dev/sda6 /usr ext3 acl,user_xattr 1 2
> /dev/hdb2 swap swap defaults 0 0
>
So it was able to find the swap.
> /dev/sda2 swap swap defaults 0 0
> proc /proc proc defaults 0 0
> sysfs /sys sysfs noauto 0 0
> debugfs /sys/kernel/debug debugfs noauto 0 0
> usbfs /proc/bus/usb usbfs noauto 0 0
> devpts /dev/pts devpts mode=0620,gid=5 0 0
> /dev/fd0 /media/floppy auto noauto,user,sync 0 0
> ----------------------------------------------------------------------------------
> (10.2 /boot/grub/menu.1st)
>
> # Modified by YaST2. Last modification on Thu Feb 1 22:04:23 EST 2007
> default 0
> timeout 8
> gfxmenu (hd2,0)/boot/message
>
> ###Don't change this comment - YaST2 identifier: Original name: linux###
> title openSUSE 10.2
> root (hd2,0)
> kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=0x31a
> resume=/dev/sda2 splash=silent showopts
> initrd /boot/initrd-2.6.18.2-34-default
>
> ###Don't change this comment - YaST2 identifier: Original name: windows###
> title Windows
> rootnoverify (hd0,0)
> chainloader (hd0,0)+1
>
> ###Don't change this comment - YaST2 identifier: Original name: floppy###
> title Floppy
> rootnoverify (hd0,0)
> chainloader (fd0)+1
>
> ###Don't change this comment - YaST2 identifier: Original name: failsafe###
> title Failsafe -- openSUSE 10.2
> root (hd2,0)
> kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=normal
> showopts ide=nodma apm=off acpi=off noresume edd=off 3
> initrd /boot/initrd-2.6.18.2-34-default
>
Add this to this file.
________________________________________________________________________________
### Added 10.0 Boot ###
title openSUSE 10.0
root (hd1,0)
kernel /vmlinuz root=/dev/hdb3 vga=0x31a resume=/dev/hdb2
splash=silent showopts
initrd /initrd
___________________________________________________________________________________
This assumes the following which I cannot be sure of with the supplied
info. I assume:
The initrd on that drive has the modules for the lvm in it.
The vmlinuz and initrd symlinks are setup properly
the lvm root partition is hdb3
Also, to make this the default boot, change default from 0 to 4
> -------------------------------------------------------------------------------------------
> My comments:
>
> OK, when I tried to do the fdisk-l /dev/hdb > 10-oparts (as root in a
> console from within 10.2) I got no output. Nothing. (Is it the number 10 or
> the capitalized IO, and is oparts capitalized?)
>
You are creating a file, nothing comes back to your screen.
> Had to drop back to level 3 before I could get any output from the command. I
> don't know how to save and paste the output from there but this is what I
> found:
>
> fdisk -l /dev/hdb gives me 3 partitions. A 1G boot partition, a 1G swap
> partition, and a 28G LVM (which I have my home and all other partions on as
> LVM's)
>
Is that one hdb3? or did you have any extended partitions?
> If I then do an fdisk -l on hdb1 (the boot partition) it tells me that hdb1
> doesn't have a valid partition table ??
>
Correct, that belongs to hdb. hdb1 IS a partition, it wouldn't need a
partition table.
> Seeing that, I do and fsck on /dev/hdb. Output is that the device is busy and
> failed (status 0x0)
> Then I do an fsck on hdb1 - says it is clean
> Then I do an fsck on hdb2 - says swap not found (error2)
> Then I do an fsck on hdb3 - says LVM2 member: not found (errror2)
> I really can't believe there is a partition table problem.
>
LVM makes this much harder than normal.
> The command > 10-Opart never produces any results. (Tried in every
> variation I could think of, as above)
>
You are just overwriting the file over and over.
> Sooooo...I guess that I am not understanding this.
>
> Mind you now, I did not TOUCH any of the partitions on hdb.
>
Good.
> To remind you, I have 3 drives. The first is hda which is an ide device that
> has Win98 and several Linux partitions (where I keep my backups, workspace
> and some not so important data) The second is hdb, another ide, where 10.0 is
> installed and most of my important personal data is stored, and the new drive
> a SATA, sda, where I installed 10.2
>
> I can go into the Yast partioner and see that everything is there.
What is the partition with the lvm called there? hdb3?
> I just
> cannot access hdb (10.0) I have to access hdb. That is where everything that
> is important resides. Maybe if I unplug the new Sata drive I will be able to
> mount that drive with the DVD?
>
Doubt it. Sorry, I am not that familiar with lvm disk notation.
> Thanks again and Please help. I'm sure it has something to do with changing
> from LILO to Grub.
No, actually it has to do with the lvm volumes.
> but then Win98 was picked up by Grub but 10.0 was not.
> Very frustrating.
>
IIRC, there was something about this in the release notes.

--
Joe Morris
Registered Linux user 231871 running openSUSE 10.2 x86_64






--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups