Mailinglist Archive: opensuse (2224 mails)

< Previous Next >
Re: [opensuse] LILO/Grub Problem
  • From: Bob S <usr@xxxxxxxxxxx>
  • Date: Sat, 3 Feb 2007 01:47:50 -0500
  • Message-id: <200702030147.50221.usr@xxxxxxxxxxx>
On Friday 02 February 2007 17:02, Bruce Marshall wrote:
> On Friday 02 February 2007 16:25, Bob S wrote:
> > When I put the 10.0 DVD into the machine and boot the installed system it
> > boots 10.2 and I have not figured out how to mount 10.0 Figured I could
> > use Yast to fix it.
> >
> > Think I could fix it from within 10.2 ??  Trouble is, I know absolutely
> > nothing about grub. Been using lilo all of these years.

Hello Bruce,
Thanks for replying
>
> Yes, you most likely can fix it from 10.2 but we would need to see (from
> the 10.2 install)
>
> /etc/fstab
>
> /boot/grub/menu.lst
>
> and also
>
> fdisk -l /dev/<the HD that 10.0 is on> > 10-0parts
>
> the 10-0parts file from the above command.
>
> In short, you will/may have to change the 10.0 /etc/fstab and the
> menu.lst if you have changed the order of the partitions for 10.0

Did not touch the hdb (10.0) drive
>
> Having the 10.2 files for the above wouldn't hurt either.

OK, some of what you requested to assist me:
--------------------------------------------------------------------------------------
(10.2 fstab)

/dev/sda1 / ext3 acl,user_xattr 1 1
/dev/sda5 /home ext3 acl,user_xattr 1 2
/dev/sda6 /usr ext3 acl,user_xattr 1 2
/dev/hdb2 swap swap defaults 0 0
/dev/sda2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
----------------------------------------------------------------------------------
(10.2 /boot/grub/menu.1st)

# Modified by YaST2. Last modification on Thu Feb 1 22:04:23 EST 2007
default 0
timeout 8
gfxmenu (hd2,0)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.2
root (hd2,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=0x31a
resume=/dev/sda2 splash=silent showopts
initrd /boot/initrd-2.6.18.2-34-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (hd0,0)
chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.2
root (hd2,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=normal
showopts ide=nodma apm=off acpi=off noresume edd=off 3
initrd /boot/initrd-2.6.18.2-34-default
-------------------------------------------------------------------------------------------
My comments:

OK, when I tried to do the fdisk-l /dev/hdb > 10-oparts (as root in a
console from within 10.2) I got no output. Nothing. (Is it the number 10 or
the capitalized IO, and is oparts capitalized?)

Had to drop back to level 3 before I could get any output from the command. I
don't know how to save and paste the output from there but this is what I
found:

fdisk -l /dev/hdb gives me 3 partitions. A 1G boot partition, a 1G swap
partition, and a 28G LVM (which I have my home and all other partions on as
LVM's)

If I then do an fdisk -l on hdb1 (the boot partition) it tells me that hdb1
doesn't have a valid partition table ??

Seeing that, I do and fsck on /dev/hdb. Output is that the device is busy and
failed (status 0x0)
Then I do an fsck on hdb1 - says it is clean
Then I do an fsck on hdb2 - says swap not found (error2)
Then I do an fsck on hdb3 - says LVM2 member: not found (errror2)
I really can't believe there is a partition table problem.

The command > 10-Opart never produces any results. (Tried in every
variation I could think of, as above)

Sooooo...I guess that I am not understanding this.

Mind you now, I did not TOUCH any of the partitions on hdb.

To remind you, I have 3 drives. The first is hda which is an ide device that
has Win98 and several Linux partitions (where I keep my backups, workspace
and some not so important data) The second is hdb, another ide, where 10.0 is
installed and most of my important personal data is stored, and the new drive
a SATA, sda, where I installed 10.2

I can go into the Yast partioner and see that everything is there. I just
cannot access hdb (10.0) I have to access hdb. That is where everything that
is important resides. Maybe if I unplug the new Sata drive I will be able to
mount that drive with the DVD?

Thanks again and Please help. I'm sure it has something to do with changing
from LILO to Grub. but then Win98 was picked up by Grub but 10.0 was not.
Very frustrating.

Bob S.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups