Mailinglist Archive: opensuse (2063 mails)

< Previous Next >
Re: [opensuse] device.map - Darryl/Carl/Boyd
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Fri, 2 Feb 2007 11:11:29 +0100 (CET)
  • Message-id: <Pine.LNX.4.64.0702021102250.5883@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


The Friday 2007-02-02 at 07:09 -0000, riccardo35@ wrote:

> 1) boot from DOS floppy [DOS vers 6 or less in my case] , and do :-
>
> fdisk /mbr

Beware of msdos fdisk!

I'm in the process of activating a big disk. I had made, in linux, a
partition for windows, loaded it from an image, then tested it. I tried
fdisk to check how did it see the partitions, run fdisk /mbr, then tried
to see if windows run, then cam back to linux.

The extended partition had been shrinked!

It should be:

/dev/hdc2 2795 38913 290125867+ f W95 Ext'd (LBA)


and was modified by dos fdisk (I did not tell it to write anything) to:

/dev/hdc2 2795 18474 125949600 f W95 Ext'd (LBA)


and there were some partitions left out of that space:

/dev/hdc13 18475 21085 20972826 83 Linux
/dev/hdc14 21086 23696 20972826 83 Linux
...

so that linux fdisk complained:

Logical partition 13 not entirely in partition 2
Logical partition 14 not entirely in partition 2


and they were not mounted.

This originates, I guess, because the disk is 320GB, and the bios doesn't
see the full size nor Windows Me, it seems - but linux does fine.


- --
Cheers,
Carlos E. R.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFFww5btTMYHG2NR9URAl2iAJ9JL9phJcxo8P7sUSBWWtwFTxw1IgCfYQji
dJ1M+TN8OU1Ov5nCeg+BVMo=
=e/9F
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >