Mailinglist Archive: opensuse (4656 mails)

< Previous Next >
[opensuse] Totally Baffled
  • From: David McMillan <skyefire@xxxxxxxxxxxx>
  • Date: Tue, 30 Jan 2007 23:30:13 -0500
  • Message-id: <45C01B55.4030804@xxxxxxxxxxxx>

I'm not even sure how to describe this, but I'll try.
Okay: I have a small NAS device attached to my home LAN which I've
been using to keep a large (~300GB) of data files on, but which is near
its storage limit. So I've been trying to set up LVM (for the first
time) on my 10.0 system, to create a larger archive to copy the data
files to. The LVM creation process went well, as far as I can tell, and
I ordered an rsync job to duplicate the original archive to the new,
expanded one.
But after about 36GB of copying, something incredibly weird happened:
my original archive vanished from the mount list, and the rsync job
stopped with a string of "no such file/directory" errors. I mean, it
just *vanished* -- stopped showing up at all when I did a df. Konq
started reporting "this directory/file no longer appears to be present"
when I tried to navigate to it. And this is on a machine that *no one*
else has access to, so I can 99% guarantee there was no human intervention.
Even stranger: I couldn't remount the NAS drive for some reason,
although using its HTTP access I was able to confirm that it was fine.
Eventually, I just gave up and rebooted. And now, this (I should note
that my NAS is normally mounted to /archives, and the LVM volume to
/archives2):

david@linux:/> ls -la
/bin/ls: archives: No such file or directory
total 35
drwxr-xr-x 27 root root 656 2007-01-30 16:12 .
drwxr-xr-x 27 root root 656 2007-01-30 16:12 ..
drwxr-xr-x 2 root root 48 2005-11-26 21:45 8thdimension
drwxr-xr-x 4 david root 104 2007-01-07 20:18 archives2
drwxr-xr-x 2 root root 2896 2006-12-09 00:15 bin
drwxr-xr-x 3 root root 1488 2007-01-07 00:32 boot
drwxr-xr-x 11 root root 15660 2007-01-30 21:12 dev
drwxr-xr-x 108 root root 9288 2007-01-30 23:11 etc
drwxr-xr-x 3 root root 72 2005-11-20 04:48 home
drwxr-xr-x 11 root root 4136 2007-01-21 16:46 lib
drwxr-xr-x 5 root root 144 2007-01-08 08:43 media
drwxr-xr-x 2 root root 48 2005-09-09 12:27 mnt
drwxr-xr-x 13 root root 344 2006-08-26 17:03 opt
dr-xr-xr-x 140 root root 0 2007-01-30 16:12 proc
drwx------ 26 root root 1376 2007-01-30 21:11 root
drwxr-xr-x 3 root root 9760 2007-01-30 19:47 sbin
drwxr-xr-x 2 root root 48 2006-06-19 19:35 sg1
drwxr-xr-x 5 root root 120 2005-11-19 20:35 srv
drwxr-xr-x 11 david root 4096 2007-01-27 00:29 storage
drwxr-xr-x 2 root root 48 2005-09-09 05:59 subdomain
drwxr-xr-x 10 root root 0 2007-01-30 16:12 sys
drwxrwxrwt 31 root root 2848 2007-01-30 23:00 tmp
drwxr-xr-x 15 root root 416 2006-11-14 09:42 usr
drwxr-xr-x 14 root root 360 2005-11-19 19:34 var
david@linux:/> sudo mkdir /archives
mkdir: cannot create directory `/archives': File exists
david@linux:/> ls /archives
/bin/ls: /archives: No such file or directory
david@linux:/>

Okay: If I mount the NAS device to /archives, the mount command
succeeds. It shows up in df as mounted, and shows me the NAS device's
format and current space used/avail. But any attempt to ls /archives
shows it as not existing. So I umounted the NAS device, and tried
again. And tried re-creating it with mkdir. And the results, you've
seen above.
I am *stumped.* This string of behaviors makes *no* sense at all. Has
anyone else ever encountered anything like this?

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups