Mailinglist Archive: opensuse (4656 mails)

< Previous Next >
Re: [opensuse] Suse 10.2 shared printer + Mac OSX
  • From: Art Fore <art.fore@xxxxxxxxxxx>
  • Date: Wed, 31 Jan 2007 11:04:28 +0800
  • Message-id: <1170212668.23095.1.camel@xxxxxxxxxxxxxxxxxxx>
On Tue, 2007-01-30 at 18:31 -0700, jim barnes wrote:
> On Tuesday 30 January 2007 07:07, Art Fore wrote:
> > Ihave a laserjet 2300 connected to my desktop lpt0 port. I can print
> > with no problem from the desktop. Went to Yast, Hardware, Printers,
> > Other and setup to allow any machine on 192.168.1.* to access the
> > printer and open port in firewall. Done the ipp permissions the same.
> > Setup the Mac for ipp printer and select laserjet 2300 and the print
> > queue name the same as on the desktop. Still am not able to print from
> > the Mac. If I look at the print queue, it always says stopped. I can
> > ping the desktop from the the Mac, so there is a connection. I can also
> > start the printing of the file in the queue, but to still comes back
> > stopped.
> >
> > Would appreciate any of you Mac enthusiasts to let me know how you got
> > it to work if of course you did, or even if you did not get it to work.
> >
> > Art
>
> I recently worked through getting two mac laptops printing to a cups server
> (>hp2200dn) running on openSUSE 10.2, from a wireless network crossing
> subnets.
>
> The first one had osx 10.4.3. The printer add utility, using the ipp settings
> worked first try. I had to watch /var/log/cups/error_log on the cups server
> and catch the username denial, then add it to /etc/cups/printers.conf using
> the AllowUser directive, being that the mac username was different than the
> 10.2 username. cups restart necessary.
> On the fly adjustments can be effected using the lpadmin command:
> /usr/sbin/lpadmin -p printername -u allow:foo_user,@bar_group
>
>
> The second one had osx 10.3.9 and was more stubborn. Using the printer setup
> utility, and selecting the ipp route again, the wrong path was sent to the
> 10.2 server and the queue was not available. The error was:
> from: /var/log/cups/access_log
> 192.168.2.4 - - [27/Jan/2007:14:13:01 -0700] "POST /ipp/printers/Dilbert\
> HTTP/1.1" 200 302 Get-Printer-Attributes client-error-not-found
> I couldn't get rid of the /ipp part, and it doesn't exist on the 10.2 server.
> osx 10.3.9 didn't allow any other suitable choices to select. I finally
> realizied osx was using cups, loaded safari > localhost:631, and added the
> printer using the http://cups_server:631/printers/printer format and it
> worked a treat! Username acknowledgment on the 10.2 cups printers.conf
> neccessary again also.
> I'll go straight to cups browser-based setup next time.
> Watch your access_log and error_log for clues.
> HTH,
> --
> Jim Barnes
> --
> Certainly the game is rigged. Don't let that stop you;
> if you don't bet, you can't win. -Lazarus Long
> --
> Linux 2.6.15-27-386

Thanks. I will try that. Hadn't thought of OSX using CUPS, but seem
reasonable now that I think about it.

Art

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References