Mailinglist Archive: opensuse (4654 mails)

< Previous Next >
Re: [opensuse] ATI Radeon X1600 has no 3D acceleration
  • From: Curtis Rey <crey@xxxxxxxxxx>
  • Date: Tue, 23 Jan 2007 21:44:52 -0800
  • Message-id: <200701232144.52786.crey@xxxxxxxxxx>
On Tuesday 23 January 2007 21:20, John Andersen wrote:
> On Tuesday 23 January 2007 16:23, Grommley Spalanski wrote:
> > . I have also
> > tried the instruction provided on the ATI website, both using the
> > installer and generating a distibution specific driver package. As well,
> > I have tried adding the ATI repository and adding the drivers through
> > YaST (this resulted in MESA drivers). Some of these instructions left me
> > with the MESA driver installed, but most of them ended with the same
> > result that I have now.
>
> CAREFULLY follow the instructions in the download from ATI, and
> build the rpm being careful to select the proper processor type.
>
> Then install the rpm
> They type this as root:
> aticonfig --initial --input=/etc/X11/xorg.conf
>
> That will build a proper xorg.conf for you.
>
> There should be no reason to go into sax2 or yast, but if you want to
> launch sax2 you can by this command
> sax2 -r -m 0=fglrx

Also, if after you get the xorg conf setup and you're still having problems
run /usr/atigetsysteminfo.sh (best as root). In my case lsmod had shown the
fglrx module loaded but it kept defaulting to Mesa software. After running
atigetsysteminfo.sh it showed that it wasn't finding the fglrx_dri.so file
but if I ran "locate fglrx_dri.so" it was indeed installed but in the wrong
directory (either in /usr/X11R6/lib/modules/ or /usr/lib/). I just had to
copy the file to the directory it said it couldn't find it in and I had 3D.

The points is that the ATI linux stuff has always been a bit on the kludgy
side and often a PITA. If not this shell script I would still probably be
cussing at ATI and swearing never to buy another of their cards (jury is
still out on this contention).

Cheers, Curtis.

--
Spammers Beware: Trespassers will be shot,
survivors will be shot again!

I don't want a politician I can believe in.
I simply want a politician I can believe!

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups