Mailinglist Archive: opensuse (4633 mails)

< Previous Next >
Re: [opensuse] Postfix Qwerkiness
  • From: "Brian Blater" <brb.lists@xxxxxxxxx>
  • Date: Mon, 22 Jan 2007 15:23:28 -0500
  • Message-id: <7743536a0701221223m40ca390by80b42550aa2beff0@xxxxxxxxxxxxxx>
On 1/22/07, Sandy Drobic <suse-linux-e@xxxxxxxxxxxxxxxxxxxxxxx> wrote:
Brian Blater wrote:
> I have a 10.2 box running as a postfix mail gateway for a couple of
> domains I have. This box is running spamassassin, maia mailguard and
> clamav. Local mail is disabled on this machine. I've setup postfix so
> that
> myhostname = mail.domain.com
> relay_domains = domain.com anotherdomain.com
> mydomain = domain.com
> relayhost = 1.2.3.4

Addresses in Postfix are qualified with the value of $myorigin, and the
default value of $myorigin is $myhostname:

# postconf -d myorigin
myorigin = $myhostname

postconf -e "myorigin = $mydomain"
postfix reload

should solve your problem.


Thanks, Sandy. This helps clarify the situation.

As for the stuff below. I'm not sure what is happening. It doesn't
appear to be reading the transport file at all and other things are
not behaving normally. I'm going to rebuild (it's a test box right now
anyways.)

> The transport file has
> domain.com smtp:[w.x.y.z]
> anotherdomain.com smtp:[w.x.y.z]
>
> The virtual file has
> root me@xxxxxxxxxx
> vscan me@xxxxxxxxxx

Don't do that! do not use unqualified addresses in virtual. Because
virtual is applied to ALL mails (also outgoing mails) any mail sent to
root@xxxxxxxxxxxxxxxxxxx will be rewritten to me@xxxxxxxxxx!

Thanks, fixed. All aliases in virtual will be FQ now.

>
> Second, in the log files I see the following:
> Jan 21 19:00:11 mail postfix/cleanup[22582]: D4BE62078D:
> message-id=<20070122000011.D4BE62078D@xxxxxxxxxxxxxxx>
> Jan 21 19:00:11 mail postfix/bounce[22585]: D07832078F: sender
> non-delivery notification: D4BE62078D
> Jan 21 19:00:11 mail postfix/qmgr[5929]: D4BE62078D: from=<>,
> size=2674, nrcpt=1 (queue active)
> Jan 21 19:00:13 mail postfix/smtp[22586]: D4BE62078D:
> to=<me@xxxxxxxxxx>, orig_to=<vscan@xxxxxxxxxxxxxxx>,
> relay=1.2.3.4[1.2.3.4]:25, delay=1.2, delays=0.01/0/0.18/1, dsn=2.0.0,
> status=sent (250 2.0.0 l0M00Cju028485 Message accepted for delivery)
> Jan 21 19:00:13 mail postfix/qmgr[5929]: D4BE62078D: removed
>
> Why is it trying to send this message to me@xxxxxxxxxx through the
> relay server 1.2.3.4 when it knows (via transport file) that this
> domain should be sent to w.x.y.z?
>
> I've done this same setup on a 10.1 box previously and it is working
> just fine. Any ideas what I'm missing? I'm just confused.

Can't help you here with incomplete und obfuscated data.

After the rebuild if this comes up again I will post unmangled log
files for you to see.

Thanks again for setting me straight.

Brian
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >