Mailinglist Archive: opensuse (4626 mails)

< Previous Next >
RE: [opensuse] fsck running amok
On Wednesday, January 17, 2007 @ 3:25 PM, I wrote:

>Well, I've done some more digging on this problem and, though I have found
>out some things, I am still no closer to solving the problem than before.

>1) The huge amount of lines in /var/log/messages seems to be unrelated to
>why I'm getting an fsck every time I boot. There are hundreds of lines in
>there that look like this one --

>Linux kernel: SFW2-IN-ACC-RELATED IN eth0
>OUT=MAC=00:08:74:24:85:82:00:04:5A:0f:18:07:08:00 SRC=128.61.111.11
>DST=192.168.1.102 LEN=529 TOS=0x00 PREC=0x00 TTL=64 ID=238936 WINDOW=1716
>RES=0x00 ACK FIN URGP=0 OPT (long hex number here)

>The DST address is my machine's internal address. I checked several of the
>SRC addresses and they seemed to all be ZEN/YOU mirrors. So, this would
>appear to be some ZEN glitch (if so, what's new). I wouldn't think this
>would have anything to do with my getting the fscks every time I boot.

>2) When I finally scrolled back across thousands of lines of the above and
>got to the beginning of the startup process, there were no messages that
>indicated any type of problem, disk related or otherwise.

>3) I tried "tune2fs -c 99 /dev/hda2" and it came back and said "Setting
>maximal mount count to 99". However, I still get an fsck every time I boot
>up.

>So, at this point I'm stumped. There doesn't seem to be any error message
>coming out and yet it just automatically does an fsck every time I boot.
>I'm going to look at some of the other files in /var/log to see if I can
>find one with some sort of message in it that would point me to why this is
>happening. Don't know what else to do at this point.

>Greg Wallace

I just noticed the following lines ahead of the fsck in the log --

Invoking userspace resume from /dev/hda1
resume: Could not stat configuration file
resume: libgcrypt version: 1.2.3
resume: Could not read the image
Invoking in-kernel resume from /dev/hda1 <-- swap
Waiting for device /dev/hda2 to appear ok
fsck...

Could the fact that it's trying to do a resume and is unable to be the cause
of the problem? I really don't need resume from disk anyway. How can I
turn that off? I'll start looking for that setting under /etc/sysconfig
Editor.

Greg W


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread