Mailinglist Archive: opensuse (4626 mails)

< Previous Next >
Re: [opensuse] vim rpm
  • From: "Andy Harrison" <aharrison@xxxxxxxxx>
  • Date: Mon, 15 Jan 2007 10:17:28 -0500
  • Message-id: <a22ff2940701150717h3fe99acfnf934c197e64bb90@xxxxxxxxxxxxxx>
On 1/14/07, Alexey Eremenko <al4321@xxxxxxxxx> wrote:
On 1/14/07, Andy Harrison <aharrison@xxxxxxxxx> wrote:
> Does anyone know where I might be able to get a regular rpm or at
> least a spec file for vim that doesn't hassle with splitting it into
> different pieces? No clue why it's been chopped up into so many
> unnecessary pieces, but it's really annoying and I'm really tired of
> having gvim ignore my .vimrc files and vim: modelines... < /grumble
> >

I'm sorry - but please explain more clearly what do you want; maybe I
can help you.
There are ways to know which files go where.

One way is:
rpm -ql vim

Other way is to use UnionFS.

Right now, instead of just installing vim, it gets broken into
separate components, vim, gvim, and vim-enhanced. These different
versions don't work together correctly. So, for example, when I have
a modeline in a file, maybe something like '# vim: et sw=3 ts=3', and
then I run gvim, this modeline is completely ignored, apparently since
it is a vim modeline, not gvim.

Also, I have a .vimrc and ~/.vim/ directory that I copy around to
different machines. However, with this split, when I run gvim, my
.vimrc file is ignored.

The default compile and install of vim is not to create this division.
So I'm just wondering if anyone has an rpm or a spec so that I could
get an uncrippled version of vim installed.

--
Andy Harrison
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >