Mailinglist Archive: opensuse (3831 mails)

< Previous Next >
[opensuse] CUPS error "client-error-not-authorized"
  • From: Mike Coan <mikecoan@xxxxxxxxxxxxxxxxxxxxxx>
  • Date: Thu, 11 Jan 2007 16:11:52 -0500
  • Message-id: <200701111611.52869.mikecoan@xxxxxxxxxxxxxxxxxxxxxx>
I recently upgraded from opensuse 10.1 to 10.2

My office has a Canon ImageRunner 2800, a networked digital
copier/printer/scanner. For these type of Canon copier/printers there is a
shell script from BrightQ that configures the device. The file is called

canon-brightq-2.3.0-linux-2006-04-14.run

and is 43 mb in size

Running this script in 10.0 and in 10.1 worked perfectly, and gave me access
to all the features of the device. Now when I run the script it is fine
until the last step, then it gives the error message

add printer failed client-error-not-authorized

This looks like a permission error to me. Note that I run the script as root.

I have checked out various sites for cups documentation, and have gone to
localhost:631 to access the CUPS web configuration. I think the relevant
section of the configuration file, /etc/cups/cupsd.conf, is

# All administration operations require an adminstrator to authenticate...
<Limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer
Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs
Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer
Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After
CUPS-Add-Printer CUPS-Delete-Printer CUPS-Add-Class CUPS-Delete-Class
CUPS-Accept-Jobs CUPS-Reject-Jobs CUPS-Set-Default>
AuthType Basic
Require user @SYSTEM
# Order deny,allow
Order allow,deny
</Limit>

At least it has the language CUPS-Add-Printer. I commented out
Order deny,allow and replaced it with Order allow,deny. that didn't help.

Please note that I can use Yast to add a printer and print to the device, but
the choices for Canon do not include the ImageRunner 2800, and specifically
do not allow me to use the envelope cassette.

Any pointers would be appreciated. One thought is to run the script on a 10.1
machine and generate the ppd file and then use that ppd file with Yast. Not
a real pleasant thought as my home machine is already upgraded to 10.2 and I
don't want to reinstall 10.1 just to configure a printer.

Mike

--
Michael A. Coan
Woodlawn Foundation
524 North Avenue, Suite 203
New Rochelle, NY 10801-3410
Tel: 914-632-3778
Fax: 914-632-5502
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups