Mailinglist Archive: opensuse (3531 mails)

< Previous Next >
Re: [opensuse] Sending mail via my ISP relay using sendmail
  • From: Sandy Drobic <suse-linux-e@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Fri, 05 Jan 2007 20:13:27 +0100
  • Message-id: <459EA357.6090705@xxxxxxxxxxxxxxxxxxxxxxx>
Paul Abrahams wrote:
On Friday 05 January 2007 12:31 pm, Sandy Drobic wrote:
Paul Abrahams wrote:
On Friday 05 January 2007 6:32 am, Carlos E. R. wrote:
The Friday 2007-01-05 at 00:28 -0500, Paul Abrahams wrote:
I'm trying to send mail through my ISP using sendmail (postfix under
the covers). I have to use sendmail because the actual application is
the PHP5 "mail" command, and that command uses sendmail. My ISP
requires a username and password to accept the relay; this protocol
goes under the name of SMTP AUTH.

How can I track down the reason the mail isn't arriving?
Aha! The log contains this:

Jan 5 10:46:59 suillus postfix/smtp[7947]: 15FEE9CE00:
to=<abrahams@xxxxxxx>, relay=smtp.comcast.net[206.18.177.17]:25,
delay=7.1,
delays=6.5/0.02/0.42/0.16, dsn=5.0.0, status=bounced (host
smtp.comcast.net[206.18.177.17] said: 550 [PERMFAIL] acm.org requires
valid sender domain (in reply to RCPT TO command))

So the real problem seems to lie with the sender domain.
It depends. Does the server smtp.comcast.net require authentication for
you to relay or does it simply check your ip and allows relaying based on
that?

smtp.comcast.net does require usename/password authentication. But that requirement seems to have been met. It appears that the problem arises when comcast attempts to send a RCPT to the sender (see log entry above) and doesn't get a valid sender domain in response.

So, what sender address DID you use when the above log entry was made?
acm.org seems to be handled by Postini, and it is possible that the comcast server tried to serve as proxy and immediately resend the smtp commands of your smtp client to the remote Postini server that is responsible for acm.org.

Try to use a different destination address (not at acm.org) for another test. Do you get the same message back?

The sender address must be a real existing address. Use the address you
expect others to answer to as the sender address, and you should not have
a problem.

I tried "sendmail -F abrahams@xxxxxxx abrahams@xxxxxxx" but that didn't work either.

What did Postfix log about that? "didn't work" is not very helpful. (^-^)
The logs show exactly what happened.

Sandy
--
List replies only please!
Please address PMs to: news-reply2 (@) japantest (.) homelinux (.) com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups