Mailinglist Archive: opensuse (3531 mails)

< Previous Next >
Re: [opensuse] Sending mail via my ISP relay using sendmail
  • From: Paul Abrahams <abrahams@xxxxxxx>
  • Date: Fri, 5 Jan 2007 13:21:09 -0500
  • Message-id: <200701051321.09493.abrahams@xxxxxxx>
On Friday 05 January 2007 12:31 pm, Sandy Drobic wrote:
> Paul Abrahams wrote:
> > On Friday 05 January 2007 6:32 am, Carlos E. R. wrote:
> >> The Friday 2007-01-05 at 00:28 -0500, Paul Abrahams wrote:
> >>> I'm trying to send mail through my ISP using sendmail (postfix under
> >>> the covers). I have to use sendmail because the actual application is
> >>> the PHP5 "mail" command, and that command uses sendmail. My ISP
> >>> requires a username and password to accept the relay; this protocol
> >>> goes under the name of SMTP AUTH.
> >>>
> >>> How can I track down the reason the mail isn't arriving?
> >
> > Aha! The log contains this:
> >
> > Jan 5 10:46:59 suillus postfix/smtp[7947]: 15FEE9CE00:
> > to=<abrahams@xxxxxxx>, relay=smtp.comcast.net[206.18.177.17]:25,
> > delay=7.1,
> > delays=6.5/0.02/0.42/0.16, dsn=5.0.0, status=bounced (host
> > smtp.comcast.net[206.18.177.17] said: 550 [PERMFAIL] acm.org requires
> > valid sender domain (in reply to RCPT TO command))
> >
> > So the real problem seems to lie with the sender domain.
>
> It depends. Does the server smtp.comcast.net require authentication for
> you to relay or does it simply check your ip and allows relaying based on
> that?

smtp.comcast.net does require usename/password authentication. But that
requirement seems to have been met. It appears that the problem arises when
comcast attempts to send a RCPT to the sender (see log entry above) and
doesn't get a valid sender domain in response.

> The sender address must be a real existing address. Use the address you
> expect others to answer to as the sender address, and you should not have
> a problem.

I tried "sendmail -F abrahams@xxxxxxx abrahams@xxxxxxx" but that didn't work
either.

> It is still possible that you will have to authenticate to the relayserver
> to be able to relay.

I think that part is working. It's the RCPT check that's failing.

> To use smtp auth with postfix:
>
> /etc/postfix/smtp_relayhost_auth:
> [smtp.comcast.net] username:password
>
> Then execute "postmap /etc/postfix/smtp_relayhost_auth"
>
> /etcp/postfix/main.cf:
> # square brackets around hostname to suppress mx lookup of relayhost
> relayhost = [smtp.comcast.net]
> smtp_sasl_auth_enable = yes
> smtp_sasl_password_maps = hash:/etc/postfix/smtp_relayhost_auth
> smtp_sasl_security_options = noanonymous
>
> After you have inserted these options, verify with the output of "postconf
> -n" that these options are active.
>
> Then execute "postfix reload" to refresh the changed configuration.
> Now send a testmail with valid sender address and recipient address.

I did all that and still no luck. I had previously used the file sasl_passwd
instead of smtp_relayhost_auth, but I assume that the filename doesn't
matter, only the contents (and the fact that the .db file has been updated).

Paul
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups