Mailinglist Archive: opensuse (3531 mails)

< Previous Next >
[opensuse] arts, alsa and oss
  • From: Clayton <smaug42@xxxxxxxxx>
  • Date: Wed, 3 Jan 2007 15:06:30 +0100
  • Message-id: <e29967880701030606o15dc9765s9b078e2ec6928436@xxxxxxxxxxxxxx>
Maybe someone here can point me in the right direction...

I'm running SUSE 10.2 and bumping into a problem with sound in a
specific application... Cedega and World of Warcraft. Basically I
have no sound at all in Cedega/WoW.

I've tinkered around a fair bit and searched... posted on the Cedega
forums etc etc.. and no solutions yet.

As best as I can figure, the problem is with how ALSA and OSS are
handled in SUSE. For whatever reason Cedega cannot see any OSS
capabilities in SUSE. I've got the ALSA OSS emulation stuff
installed... I've checked that.

If I run the Cedega tests it fails the OSS support test. If I force
it to use OSS in the Cedega setup, I'm met with silence. (As an
experiment, I've also tried telling KDE to use OSS instead of ALSA,
and it does not work)

As a comparison, I've also got Kubuntu (6.10) installed, and under
Kubuntu, and sound works perfectly... if I'm using the OSS option in
the audio tab (in the setup in Cedega). Also, when I run the Cedega
tests, it passes the OSS test.

So... the hardware supports whatever is needed, the application
works... the game works... just not in SUSE.

Does anyone have any suggestions or ideas on this... what can be done
to convince Cedega (or anything else for that matter - eg KDE) to use
OSS on SUSE?

C.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups