Mailinglist Archive: opensuse (3893 mails)

< Previous Next >
Re: [opensuse] PCTEL 2304WT v.92 MDC Modem on Dell Laptop
  • From: Felix Miata <mrmazda@xxxxxx>
  • Date: Tue, 02 Jan 2007 18:41:40 -0500
  • Message-id: <459AEDB4.1050906@xxxxxx>
On 2007/01/02 10:28 (GMT-0500) Felix Miata apparently typed:

> The sticker on the bottom says Latitude C510/C610, but in messing with
> this thing (not mine, bought used by its current clueless owner) I've
> also seen indications this might be a C640.

> It was given to me to "fix" the modem under W2K, when his original
> problem was a screwed up ISP with non-working phone numbers. He deleted
> files for inexplicable reasons only he understands in typical clueless
> fashion, causing the modem to be driverless.

> I tried for a while to figure out how to install a good driver, but
> without success, as it seemed the system was overwhelmed with junkware.
> So I decided to start clean by repartitioning dual boot. First I
> installed XP using a Dell OEM CD. That install went nicely, except if
> failed to find a modem driver. I tried the driver on the M$ updates
> site, but that didn't work. Then I used the Dell service tag number to
> find one, and it gave me a selection of different modem possibilities. I
> tried one or two of those without success, so proceeded to install 10.0
> from the boxed DVD I bought.

> 10.0 install went nicely, and when done, the modem worked. So I tried
> again with XP, and managed to find a driver that does work. Then I
> decided he should have the latest SUSE, and did a clean HTTP install of
> 10.2. Now it has no modem under SUSE. :-(

> lspci says the following about it:
> 00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev
> 02) (prog-if 00 [Generic])
> Subsystem: PCTel Inc Dell Inspiron 2100 internal modem
> Flags: medium devsel, IRQ 5
> I/O ports at d400 [disabled] [size=256]
> I/O ports at dc00 [disabled] [size=128]

> Why wasn't 10.2 smart enough to install a working modem driver? Is this
> a proprietary software thing, a driver included on the boxed 10.0 DVD,
> omitted from the free editions? Can this be easily fixed after adding
> the packman & guru sources? Anyone using one of these laptops who can
> provide a short course on getting the right driver installed?

I did another fresh 10.2 install, but this time from the boxed DVD. No
change in results. Also I can't figure out what tool is supposedly
provided for diagnosing proper modem function. KInternet is definitely
no prize application either. This is really the pits considering 10.0
worked fine right out of the gate. :-(
--
"I have come that they may have life, and have it to the full."
John 10:10 NIV

Team OS/2 ** Reg. Linux User #211409

Felix Miata *** http://mrmazda.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References