Mailinglist Archive: opensuse (4633 mails)

< Previous Next >
Re: [opensuse] Missing swt.jar ( Suse 10 )
  • From: Randall R Schulz <rschulz@xxxxxxxxx>
  • Date: Thu, 28 Dec 2006 14:09:42 -0800
  • Message-id: <200612281409.42526.rschulz@xxxxxxxxx>
On Thursday 28 December 2006 14:00, Kai Ponte wrote:
> On Thursday 28 December 2006 13:27, Francesco Scaglioni wrote:
> > ./configure
> > --with-swt=/usr/share/eclipse/plugins/org.eclipse.swt.gtk.linux.x86
> >_3.1.0.j ar
> >
> > then configure runs fine, without errors.
> >
> > Then make runs without errors. However, following a make
> > install (and male clean), running the program results in :
> >
> > !!! An unhandled exception occured: class
> > java.lang.UnsatisfiedLinkError --- iriverter 0.16
> > ---
> > --- Settings:
> > ---
> > ---
> > !!! no swt-pi-gtk-3138 in java.library.path
>
> AFAIK, you need the org.eclipse.swt.gtk.freebsd.x86_3.1.0.jar file.
> Make sure you reference it or at least extract that file.

Why the FreeBSD JAR file? The native code portion of SWT is
platform-specific. I'm not sure about the Java part, but it's
conceivable there is a different breakdown of the pure Java vs. native
methods that would make the JAR file platform-specific, too.

In any event, if the JAR file name includes a OS designation, I'd say
use it only on that OS.


> --
> kai - theperfectreign@xxxxxxxxx


Randall Schulz
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups