Mailinglist Archive: opensuse (4634 mails)

< Previous Next >
Re: [opensuse] Package manager problems in 10.2???
  • From: "Dominique Leuenberger" <Dominique.Leuenberger@xxxxxxxxxxxxx>
  • Date: Tue, 19 Dec 2006 13:46:15 +0100
  • Message-id: <4587FB370200001500071C26@xxxxxxxxxxxxx>


>>> Reply on 19-12-2006 14:44:31 <<<

>
> Is the package manager still that problematic in 10.2 or is there
now
> something wrong with the repo (which used to work)
>
> I have a repo added a few weeks ago (vlc) and it worked. Now, if I
want
> to add it again or refresh, it fails.
> It is very similiar to bug 226084
> (https://bugzilla.novell.com/show_bug.cgi?id=226084)
>
> I tried it in yast and rug.
>
> - Yast complains as in the bugreport
> - rug asks me wether I want to trust the key with invalid data..
when
> downloading the file repomd.xml.key from the server, gpg is
perfectly
> able to read it.
>
>
> What is going on?
>
> It's about the repo
> http://download.videolan.org/pub/videolan/vlc/0.8.6/SuSE/10.2
>
> Any help would be appreciated.
> Thnks very much,

I think the problem could be spotted... (maybe also valuable for the
report mentioned above?)
The repomd.xml.asc file is not a detached sig, but the same file, gpg
signed. And of course all these tools fail parsing it.

It seems when creating the repodata / signing it, the commandline was
wrong. So in this case, nothing wrong with the Yast / rug / zypper...
just a bit an irritating error message.

Regards,
Dominique
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >