Mailinglist Archive: opensuse (4634 mails)

< Previous Next >
[opensuse] NX problem at 10.2
  • From: "Elvis Chen" <chene77@xxxxxxxxxxx>
  • Date: Mon, 18 Dec 2006 20:08:10 +0000
  • Message-id: <BAY122-F7B162ACB4617EB0818951AAC90@xxxxxxx>
hi all,

I am having some problems with NX server on a fresh-installed 10.2. I have searched through the list but the previous posts didn't help much. I seek your advise.

I have recently installed Suse 10.2 (x86_64) on a clean harddrive. With it, the following components relating to NX are installed:

FreeNX-0.5.0-25
NX-1.5.0-73
nxclient-2.1.0-9 (from nomachine)

I set up the nxserver by running the following command as root:

nxsetup --install --setup-nomachine-key --clean

and rebooted the machine (may not be needed).

However, from multiple machines, I was not able to connect to the nxserver. All traffic are tunneled through ssh/ssl, and X11-forwarding are enabled on both the client and the server computers. The user is authenticated, the x11-protocol are established, then the nxclient sorts hangs for a while, and returns with the following error message:

"No response received from the remote server.
Do you want to terminate the current session?"

If I clicked on "YES", and then select the "detail", the following error message is given:

Copyright (C) 2001, 2006 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '22750'.
Session: Starting session at 'Mon Dec 18 15:05:53 2006'.
Warning: Connected to remote NXPROXY version 1.5.0 with local version 2.1.0.
Info: Synchronizing local and remote caches.
Info: Handshaking with remote proxy completed.
Warning: Font server connections not supported by the remote proxy.
Info: Using adsl link parameters 512/24/1/0.
Info: Using cache parameters 4/262144/8192KB/8192KB.
Info: Using image streaming parameters 50/128/1024KB/2048/256.
Info: Using image cache parameters 1/1/32768KB.
Info: Using pack method '16m-jpeg-7' with session 'unix-kde'.
Info: Using ZLIB data compression 3/3/32.
Info: Using ZLIB stream compression 6/6.
Info: No suitable cache file found.
Session: Session started at 'Mon Dec 18 15:05:53 2006'.
Info: Established X server connection.
Info: Using shared memory parameters 1/2048K.
Warning: No data received from remote proxy within 30 seconds.
Session: Terminating session at 'Mon Dec 18 15:06:31 2006'.
Info: End of NX transport requested by signal '15'.


I get a similar error message when the client is running from the server machine.

Can someone please shed some lights into what might be wrong with my setup?

tia,

_________________________________________________________________
Off to school, going on a trip, or moving? Windows Live (MSN) Messenger lets you stay in touch with friends and family wherever you go. Click here to find out how to sign up! http://www.telusmobility.com/msnxbox/

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >