Mailinglist Archive: opensuse (4301 mails)

< Previous Next >
Re: [opensuse] New ATI fglrx driver version - supports 10.2
  • From: Curtis Rey <crey@xxxxxxxxxx>
  • Date: Wed, 13 Dec 2006 19:17:27 -0800
  • Message-id: <200612131917.32296.crey@xxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wed December 13 2006 18:23, Dan Chesmore wrote:
> On Wed, 2006-12-13 at 18:06 -0800, Curtis Rey wrote:
> > -----BEGIN PGP SIGNED MESSAGE-----
> > Hash: SHA1
> >
> > On Wed December 13 2006 16:21, Curtis Rey wrote:
> > > On Wed December 13 2006 13:51, Sorin Peste wrote:
> > > > http://ati.de/support/drivers/linux/linux-radeon.html
> > > >
> > > > The release notes page is not up yet. The following is from their RSS
> > > > feed.
> > > >
> > > > Sorin
> > >
> > > Thanks Sorin. Much anticipated news - let's hope there's no major
> > > cludge.
> > >
> > > Cheers, Curtis.
> >
> > Nope! Install went ok, or so it seemed. But it reverts to Mesa for dri.
> >
> > glxinfo | grep render
> > direct rendering: No
> > GLX_ATI_pixel_format_float, GLX_ATI_render_texture
> > OpenGL renderer string: Mesa GLX Indirect
> >
> > I'll check the logs. The xorg conf looks ok, glx and dri are in the
> > modules section and the driver section does indeed have fglrx as well.
> >
> > One thing that I note is that the rpm generated refers to 7.1 if I'm
> > reading it right. fglrx_7_1_0_SUSE102-8.32.5-1.i386.rpm
> >
> > I'll post if I find out anything relevant.
>
> It worked for me:
>
> direct rendering: Yes
> GLX_ATI_pixel_format_float, GLX_ATI_render_texture
> OpenGL renderer string: RADEON XPRESS Series Generic

I get this when running fgl_glxgears:


Using GLX_SGIX_pbuffer
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 159 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 35
Current serial number in output stream: 35

My card is a 9600XT, sounds like your running on-board ati chip? Or is it
PCI-X.

Because you got yours running doesn't mean much considering the difference in
chipsets. Previously using 10.0 I had no problem whatsoever in this arena
<shrugs>.

Cheers, Curtis
- --
Spammers Beware: Trespassers will be shot,
survivors will be shot again!

Like the song say: "Everything's 'Zen'... I don't think so"!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFgMJM7CQBg4DqqCwRAkO+AJoCKY1O4HJ0bXh0zgLoLJq1VUMJnwCgp4sc
S08e3s6CYfjF+gt297GZOqo=
=GHgb
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >