Mailinglist Archive: opensuse (4294 mails)

< Previous Next >
Re: [opensuse] amavisd-upgrade
  • From: Sandy Drobic <suse-linux-e@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Wed, 13 Dec 2006 12:14:55 +0100
  • Message-id: <457FE0AF.3080900@xxxxxxxxxxxxxxxxxxxxxxx>
Hans du Plooy wrote:
On Tue, 2006-12-12 at 23:30 +0100, Sandy Drobic wrote:
You really don't need an rpm to upgrade amavisd-new. There are only a few files that make the entire amavisd-new package, and those are easily copied by hand.
The bigger part of the preparation is the check that all neccessary requirements are met (neccessary perl modules and utilities, the docs explain very nicely what installation requirements amavisd-new has. Most of it can be installed through the CPAN shell.

Sandy, thanks. I know I cand do it through CPAN (I'm tempted), but as
it stands I'm handing this box over to someone who's not so experienced
with linux, and I want to avoid a situation where a YOU updated messes
it up. Also, I'd like to keep the rpm database intact, for the same
reason.

In that case I would give up on upgrading Amavisd-new to a recent version. There are too many dependencies on external recent packages. Better work with what you have. Maybe it would be a good idea to update the entire server to a supported version?

Sandy
--
List replies only please!
Please address PMs to: news-reply2 (@) japantest (.) homelinux (.) com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >