Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
Re: [opensuse] Where does SUSE store RPM macros and arch
  • From: "Brett I. Holcomb" <brettholcomb@xxxxxxxxxxxxx>
  • Date: Mon, 11 Dec 2006 00:01:21 -0500
  • Message-id: <200612110001.22259.brettholcomb@xxxxxxxxxxxxx>
Thanks for the help. For the record here's what I found after digging through
docs on various sites, and trying things.

RPM is supposed to use macros in /usr/lib/rpm - which it does - and these for
the files in /etc/rpm. This is what I get when I ran rpmbuild --showrc on a
untouchec system.

/etc/rpm/macros.*:/etc/rpm/macros:/etc/rpm/pentium3-linux/macros:

and this for the user.

~/.rpmmacros


I tried creating a .rpmmacros file and added this to it as the only entry.
There were no files in /etc/rpm.

buildarchtranslate: pentium3: i686

This did not work until I created a symlink to ~/.rpmrc and then ran
rpmbuild --showrc and then my build arch was a i686. Although ~/.rpmrc is
supposed to be deprecated it appears to be what SUSE uses.

After digging through the various files in /usr/lib/rpm and other documents I
then decided to try a site file and put an rpmrc in /etc/rpm - that did not
work. I even created a /etc/rpm/macros directory and put an rpmrc file in
it - no luck. However, putting an rpmrc file in /etc makes it work.

If anyone has any docs that explain what OpenSUSE 10.1 really use I'd
apprecaite it because I wonder why the paths listed above in /etc/ don't
work. I found a reference to /etc/rpmrc in /usr/lib/rpm/convertrpmrc.sh
which script is supposed to convert macros in /etc/rpmrc to their equivalents
in /etc/rpm and /etc/rpm/macros.

So for now I created an /etc/rpmrc with the one entry for buildtranslate and
it sees the build arch as i686.


On Sunday 10 December 2006 18:10, Joe Morris (NTM) wrote:
> Brett I. Holcomb wrote:
> > Where do I find the rpmmacros files that OpenSUSE 10.1 sets this in?
>
> You can just use the --target=i686 option to rpmbuild.

> --
> Joe Morris
> Registered Linux user 231871

--

Brett I. Holcomb
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >