Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
[opensuse] SUSE 10.2 + (X)vnc
  • From: Michal Libra <linux@xxxxxxxxxx>
  • Date: Sun, 10 Dec 2006 13:25:33 +0100
  • Message-id: <457BFCBD.8090501@xxxxxxxxxx>
Hi,

need a help with configuring VNC server on openSuse 10.2.

I'm using vnc server as a Xorg module called vnc (or Xvnc).
My requirements are very simple, I want to connect to display :0 on the PC and use an existing X session (using port 5900).

On previous version of Suse it worked this way. I just enabled Remote administration in Yast and then Enabled Vnc in the SaX utility.

In Suse 10.2 something changed. Maybe it's becouse of the new Xorg (now 7.2).
When I use identical steps to enable VNC, my Xorg starts VNC only on port 5901 and every connection starts a new X session.

I found Xvnc man page but it didn't help me anyway.
I also made a comparison of the new and old xorg.conf files. But there were only some minor differences.

How can I change behavior of the vnc module?

Thanks for any suggestions.

Michal




Some relevant lines from my xorg.conf :

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
Load "vnc"
EndSection

Section "Device"
BoardName "GeForce2 MX/MX 400"
BusID "1:0:0"
Driver "nv"
Identifier "Device[0]"
Option "usevnc" "yes"
Option "rfbauth" "/root/.vnc/passwd"
Screen 0
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Keyboard[2]" "ExtraKeyboard"
InputDevice "Mouse[3]" "ExtraPointer"
Option "Clone" "off"
Option "VNC" "3 2"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups