Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
Re: [opensuse] OpenOffice.org only 32bit?
  • From: "Joe Morris (NTM)" <Joe_Morris@xxxxxxx>
  • Date: Sun, 10 Dec 2006 19:04:11 +0800
  • Message-id: <457BE9AB.7060100@xxxxxxx>
Thibaut Cousin wrote:
> I installed the x86_64 version of 10.2, everything works fine. :-)
> I was only surprised to see that OpenOffice.org is only available as 32bit.
> A quick look in the source RPM shows the reason: it doesn't work with Sun
> Java in 64bit.
? It does here. I didn't check the source.rpm.
> I don't understand: in 10.1, I had both in 64bit and it worked
> well.
> Anyway, could it work with GCC-Java 64bit? I've tried recompiling it, but it
> failed (I forgot the error message, so I'm trying again now to get it).
>
I don't know about that.
> The result, through RPM dependency, is a mess of 32bit packages that waste
> space in my system. In 10.1 I was able to remove almost all of them by
> installed 64bit versions of everything.
>
> Would it be possible to provide 64bit packages of OpenOffice.org relying on
> another Java like GCC-Java? Does it alreadly exist in a RPM-MD repository?
> Thanks in advance,
>
>
My understanding was it was pulled because it is such a huge package it
wouldn't fit on the DVD9, so they only included the i586 version. You
can get the x86_64 rpms from Factory repository. It does need x86_64
java, i.e. java-1.5.0-sun x86_64. HTH


--
Joe Morris
Registered Linux user 231871






--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References