Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
Re: [opensuse] 10.2 and GRUB
  • From: "Joe Morris (NTM)" <Joe_Morris@xxxxxxx>
  • Date: Sun, 10 Dec 2006 08:37:45 +0800
  • Message-id: <457B56D9.4020903@xxxxxxx>
Ed Harrison wrote:
> I will attest from the beginning that I made a mistake in upgrading 10.1 to 10.2.
>
> That said, here is the problem. Grub loads stage 1.5. Then GRUB is Loading. Please Wait...
>
Sounds like it cannot find your boot directory. Odd, since that is
where stage 1.5 is. What is your file system?
> I tried the grub command line:
>
> root (hd0,4)>>setup (hd0)
>
I would suggest booting with the rescue system, mounting your / to /mnt,
and if you have a separate boot partition mounting it to /mnt/boot, then
cd to /mnt, then chroot /mnt. Then, enter grub, run root (hd0,4), then
setup (hd0) and make sure it finds everything and there are no errors.
quit to exit grub, then exit to exit the chroot, then shutdown -r now to
reboot. That process has always worked for me. All this assumes config
files are correct, like your menu.lst, initrd, etc.


--
Joe Morris
Registered Linux user 231871






--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References