Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
[opensuse] Upgrade KDE 3.5.1a to 3.5.5 on 10.1
The current version of KDE for SUSE 10.1 that is
available for upgrade via smart is KDE 3.5.5.
This version is much newer than the version
of KDE that was provided on 10.1 DVD - KDE 3.5.1a.

10.1 (re-mastered, but I believe it was the same
for the original 10.1 on the boxed DVD) includes
libexpat.so.1.5.? as part of the widely used expat
package, and has links to it, pretending to be
libexpat.so.1. The links appear to satisfy other
installed packages/applications that need the older version.

Smart says it can't install 3.5.5 because "... no
package provides libexpat.so.1"

One does not wish to replace the existing libexpat.so.1.5
with an earlier version and break several dozen
installed programs. But smart doesn't seem to
be fooled by the links that are good enough for
the programs that were installed with the 10.1 (re-mastered)
installation.

So, what does one do now?

How to satisfy the KDE 3.5.5 packager's requirement
for an earlier library than the installed one?
Or how to fool smart into seeing and accepting a link
as the real thing?

I did perform an rpm database rebuild. No change.

Thank you.

Kevin

The information contained in this electronic mail transmission may be privileged and confidential, and therefore, protected from disclosure. If you have received this communication in error, please notify us immediately by replying to this message and deleting it from your computer without copying or disclosing it.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups