Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
[opensuse] Pinnacle PCTV Pro radio stopped working
  • From: Adriaan van Nijendaal <adriaan@xxxxxxxxx>
  • Date: Wed, 6 Dec 2006 11:00:44 +0100 (CET)
  • Message-id: <Pine.LNX.4.64.0612061037480.19354@xxxxxxxxxxxxxxx>
Good morning!

I have a Pinnacle PC/TV Pro with radio that used to work under SuSE
9.3. Parameters for bttv: "options bttv autoload=1 card=52 pll=2
radio=1 tuner=0"

In SuSE 10.1 (bttv 0.9.16) the TV does work, but the radio does NOT.
And that's the thing I really miss...

I read the kernel source and started trying things:

pll=0 -> no message in syslog
pll=1 -> "PLL: 28636363 => 35468950 ..........failed"
pll=2 -> "PLL can sleep, using XTAL (35468950)"

card=39 -> seems to work, but puts "PLL: 28636363 => 35468950
..........failed" in syslog anytime I change a channel with tvtime.

tuner=0,1,2,5, -> I gave up after a while - the combinations are too
many

The ting that _really_ puzzles me is that tuning to 100.45 Mhz FM
gives me FM radio with all of the above combinations. But my favorite
station broadcasts at 98.6... :-( At most other frequencies I hear
nothing (not even static). Is it a tuner problem? A phase lock loop? A
stereo decoder? A mixer?

It's an PC/TV Pro with an BT848, Philips TDA9800, TSA5522T, TDA5737M
and two crystals 35.46895 and 28.63636 in a tin box. The Radio
piggyback has an MSP3410D, Philips TDA1308 and once chip I cannot read
without desoldering something.

I've searched for the chip datasheets but I cannot understand them - I
know nothing about TV (or radio) electronics.

Question:

Any ideas as to how to get the radio on a PC/TV Pro to work under
10.1?

Thanks in advance,

Adriaan
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >