Mailinglist Archive: opensuse (2835 mails)

< Previous Next >
[opensuse] Re: [SLE] SUSE9.3 - SUSE Plugger problem with USB Serial port cable
  • From: Bruce Samhaber <bsamhaber@xxxxxxxxxxxx>
  • Date: Tue, 5 Dec 2006 14:14:15 -0500
  • Message-id: <BAYC1-PASMTP09F3F3F6BCD1988E4B0918D0DE0@xxxxxxx>
  • Message-id: <200612051414.16054.bsamhaber@xxxxxxxxxxxx>
Hi,

Here is some more info on this that might help someone. Note that I was
previously using SUSE 9.3 and am now using SUSE 10.1.

The Serial Port number was increased was because I had a link to /dev/ttyUSB0
/dev # ls -als | grep USB
0 lrwxrwxrwx 1 root root 12 2006-11-28 10:44 pilot -> /dev/ttyUSB0
0 crw-rw---- 1 root uucp 188, 0 2006-11-27 16:12 ttyUSB0

When the USB Serial port cable is unplugged and re-inserted then it (usbfs)
would create a new device /dev/ttyUSB1, however, if the USB Serial cable is
removed then this new device disappears. Therefore, I guessed
that /dev/ttyUSB0 is not being removed because it is in use, or appears to be
because of the link. Removal of the link to /dev/ttyUSB0 fixed the problem.

Note that to get Kpilot to work, it must be pointed directly to /dev/ttyUSB0.

However, for the same reason if there is an application that is pointing at
the device then the application needs to be terminated to allow the device to
be released so that it can be reassigned by usbfs.

It would be nice if the usbfs module would send a popup window message to the
appropriate user (or all users) that the device has been removed and that
application "xxxx" is still using the device.

Cheers, I hope this helps someone.



On Friday 03 March 2006 00:54, Bruce Samhaber wrote:
> Hi,
>
> I am using a USB to Serial port cable. Initially when I start the computer
> and linux then insert the USB Serial port cable the device is set
> as /dev/ttyUSB0. If the USB Serial Port cable is removed then reinserted
> it becomes /dev/ttyUSB1. Each time the USB Port cable is removed then
> reinserted the device name is increased by one.
>
> It appears to me that upon removeal of the device that SUSE Plugger is no
> removeing the device from the device list.
>
> Has anyone seen this problem?
> Does anyone have any suggestions to fix this?
>
> Thanks,
>
>
>
> --
> Bruce Samhaber
> Senior Hardware Design Consultant
> Tel: 613-724-5987 112 Kenora St.
> Fax: 613-724-5987 Ottawa, Ontario
> Cel: 613-297-6961 K1Y 3L1
> mailto: bsamhaber@xxxxxxxxxxxx http://www3.sympatico.ca/marypat/

--
Bruce Samhaber
Senior Hardware Design Consultant
Tel: 613-724-5987 112 Kenora St.
Fax: 613-724-5987 Ottawa, Ontario
Cel: 613-297-6961 K1Y 3L1
mailto: bsamhaber@xxxxxxxxxxxx http://www3.sympatico.ca/marypat/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages