Mailinglist Archive: opensuse (4219 mails)

< Previous Next >
Re: [opensuse] grub doesnt boot my system anymore, caught in endless reboot loop
  • From: "Mathias Homann" <admin@xxxxxxxxxx>
  • Date: Fri, 1 Dec 2006 10:50:11 +0100 (CET)
  • Message-id: <35291.213.61.7.196.1164966611.squirrel@xxxxxxxxxxxxxxxxxxxxx>

Darryl Gregorash schrieb:
> On 2006-12-01 03:05, Mathias Homann wrote:
>> Hallo,
>>
>> Hi,
>>
>> I'm in serious trouble here, can't get grub to boot my box anymore.
>> Instead of showing the grub boot menu, it reboots.
>
> Grub has to store some absolute file locations in the MBR area, because
> stage 1 doesn't know about file systems. It looks as if the file
> locations have changed when you restored the files.
>
> Start the rescue system on the installation CD/DVD and mount the
> installed root (/) filesystem to any convenient place, eg /mnt (if
> necessary, create the mount point). If you have separate /boot and /usr
> partitions, you will also need to mount those to /mnt/boot and /mnt/usr,
> respectively.
>
> Now do a "chroot /mnt" followed by "grub-install hd0" to re-install grub
> into the MBR of hd0.

as i've written in my previous email, i've done that already. several times. from within yast,
and from a shell.


>
> Note: you may wish to verify that hd0 is the scsi drive. This
> information is in /boot/grub/device.map


which i posted in my previous email. which is how it should be on my system.



bye,
MH



--
Die unaufgeforderte Zusendung einer Werbemail an Privatleute verstößt gegen §1 UWG und §823 I
BGB (Beschluß des LG Berlin vom 2.8.1998 Az: 16 O 201/98). Jede kommerzielle Nutzung der
übermittelten persönlichen Daten sowie deren Weitergabe an Dritte ist ausdrücklich untersagt!

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups