Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] DjVuLibre
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Mon, 3 Jul 2006 01:35:17 +0200 (CEST)
  • Message-id: <Pine.LNX.4.61.0607030002400.31373@xxxxxxxxxxxxxxxx>
Hash: SHA1

The Sunday 2006-07-02 at 16:50 -0400, Felix Miata wrote:

> > DjVu is included in 9.3 and earlier, so I suppose it is also included with
> > 10.0.
> It's old enough I expected it should be, but 3 separate YaST searches
> came up empty for me. After your reply, I went straight to the DVD, and
> there it was. I have /tmp/rpm setup as one of my sources. I copied that
> RPM there. YaST still couldn't find it, so I did it manually with rpm
> -ivh.

Funny. I don't have 10.0, I can't try.

> It works in Firefox, but Konq still doesn't know about it. I tried
> manually adding image type x-djvu with, but that didn't
> work. Anyone know what it takes to make Konq smarter?

I don't know. Does Konq usually work with mozilla plugins?

I don't even know what dir are Konq plugins stored.

I tried something. I tried to load a random djvu file in konq, and it
complained thus:

Unable to load Netscape plugin for file:///.....dvju

and in the xterm I had used to start konq from (I'm using gnome), I got

nspluginviewer (plugin): ERROR: Can't create plugin class

However, I then went searching, and hit onto "load view profile" and
choosed "Midnight Commander" (I was searching for a plugin settings menu).
Double clicking in an image fails with the same error, but passing the
mouse over it makes pop up a preview of the djvu file... and it is
correct! And the "icon view" is also correct.


I didn't know that konq could display djvu files, even if not completely.
It is not a widely supported format, and that's a pity: it is a very good
format for scanned material.

I then tried Nautilus, and I was surprised again because the icons did
show the contents correctly (double click fires up DjView). I say
surprised, because I had tried this previously and did not work (the icon
miniview). In fact, if I go to another folder, the icon preview does not
work. Weird! perhaps it only works if konq has made the preview

- --
Carlos Robinson
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Made with pgp4pine 1.76


Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at
Please read the FAQs: suse-linux-e-faq@xxxxxxxx

< Previous Next >