Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] wikimedia: math requires ocaml. (compile problem on AMD 64)
  • From: "Joe Morris (NTM)" <Joe_Morris@xxxxxxx>
  • Date: Tue, 04 Jul 2006 18:54:07 +0800
  • Message-id: <44AA48CF.1050506@xxxxxxx>
CS - Ronald Wiplinger wrote:
> I need math funtion for wiki, which requires to install ocaml.
>
> I could not compile ocaml on a AMD 64. I got the following errors:
>
> gcc -I../../byterun -I/usr/X11R6/include -O -fno-defer-pop -Wall
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT -fPIC -c -o subwindow.o subwindow.c
> ../../boot/ocamlrun ../../tools/ocamlmklib -o graphics open.o draw.o
> fill.o color.o text.o image.o make_img.o dump_img.o point_col.o
> sound.o events.o subwindow.o -L/usr/X11R6/lib -lX11
The path is wrong for the X11 libraries. You should pass an argument
something like --with-x11-libs=/usr/X11R6/lib64 to your configure script


--
Joe Morris
Registered Linux user 231871






--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >