Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] yast: "Another process is accessing..."
  • From: "Greg Freemyer" <greg.freemyer@xxxxxxxxx>
  • Date: Thu, 13 Jul 2006 12:25:48 -0400
  • Message-id: <87f94c370607130925x4a2cea99m1f2c9d7881400092@xxxxxxxxxxxxxx>
On 7/13/06, stephan beal <stephan@xxxxxxxx> wrote:
Hi, all!

i'm new to this list, and i apologize if this is not the place for this
type of question (if it is, please kindly ignore me or point me to the
proper place).

i'm using OpenSuse 10.1 and have the following problem:

Some days ago i tried to add an ftp site as an Installation Source using
yast. Each time i tried (3 or 4 times) yast hung (i waited for 5+
minutes each time) and i had to kill it. At some point it got in a bad
state, and now each time i try to use yast's Software Management or
Installation Source features i get the following error message:

"Another process is accessing the package database.
Package management will not work!"

There are no running yast processes except for the one i'm getting the
error in. i can find no stale lock files for older instances.

Other than the inability to add/remove software (or package
repositories) via yast my box is working just fine. i am able to
un/install RPMs directly from the command line.

Can someone please tell me what file(s) i need to nuke to get rid of
this error? i've tried re-installing the yast core RPMs, but that
hasn't helped. i don't mind hosing my current yast configuration in
order to get around this problem.

Note: i am an advanced user, so don't be afraid to suggest an ugly hack,
nor do you need to feel compelled to dumb down an answer for me. :)

Many thanks in advance for any tips...

--
----- stephan@xxxxxxxx http://s11n.net
"...pleasure is a grace and is not obedient to the commands
of the will." -- Alan W. Watts


Stephan,

I asked the same question a week or two ago. Got no answer.

I had the luxury of trying a reboot. It cleared the problem for me,
so the locking is either in RAM or the lock file is cleared by the
init scripts.

If rebooting is not an option, you could look at the IPC stuff and see
if it is a memory resident lock. (ipcs will give you status) ie.
maybe they are using a shared memory segment or a semaphore to control
the lock.

I just looked on my pretty vanilla server and I have 4 shared memory
segments and 3 semaphores. I don't really know what they are being
used for.

Greg
--
Greg Freemyer
The Norcross Group
Forensics for the 21st Century

--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
Follow Ups
References