Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] Almost in a panic here...
  • From: yonaton@xxxxxxxxxxxx
  • Date: Sun, 16 Jul 2006 12:26:27 -0400
  • Message-id: <20060716122627.og6g4d2y69voc4k4@xxxxxxxxxxxxxxxxxxxx>
Quoting praxis <praxis@xxxxxxxxxxxxxxxxxxxxxxx>:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: RIPEMD160

yonaton@xxxxxxxxxxxx wrote:

Hi gang,

I think I've screwed up in a major way. I use SuSE 9.3 by the way.

Last night I tried to undo the manual mounting thing I'd read about on
this list some time back (something with .fdi), but couldn't remember
what it was, so I just deleted the .fdi file I'd created so I could get
automounting back (for my DVD and DVD-Recorder). That didn't seem to
make any difference, so I then went to fstab and removed the one I'd
made and went back to the original. That didn't work either. So, I
deleted fstab in the hopes that it would just recreate itself when I
rebooted.

That wasn't wise it seems. I had to start with the SuSE DVD and tried
to 'repair' everything (I chose 'automatic' repair). All seemed well and
I rebooted.

Now, my system can't see my 'user' directories anywhere. I can log into
root (obviously) but when I try to log into 'john' I get a pop-up window
that reads 'Could not start kstartupconfig. Check your installation.'

As root, I open konqueror to browse directories and when I click on
'home' there's nothing there.

I'm really starting to get worried that I messed something up very
badly, but I'm hoping that someone out there can help me figure out what
to do to fix it. I'll stay on as root for now to check my mail (I have
no other choice at the moment) as often as possible.

Thanks to anyone and everyone willing to help me with this problem.

John


Okay. John--
Let's go through this step by step. It sounds like you have a linux
crisis...I'll do my best to help you, and I'm sure some of the other
members of this list will pitch in.
Apparently you deleted your fstab entry. You need to ascertain where
your directories are, and then determine if they are intact.
One quick way to do this to use the "-l" facility of the fdisk command,
which looks like this:

yourhostname:/# fdisk -l /dev/hda
yourhostname:/# fdisk -l /dev/hdb

Do this, and post your results to your next email. so we can take a look
at them.

Here's what I got:

Disk /dev/hda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 128 1028128+ 82 Linux swap / Solaris
/dev/hda2 129 4045 31463302+ 83 Linux
/dev/hda3 * 4046 4436 3140707+ 83 Linux
/dev/hda4 4437 9964 44403660 83 Linux

Disk /dev/hdb: 40.9 GB, 40982151168 bytes
255 heads, 63 sectors/track, 4982 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 4982 40017883+ 83 Linux

It's possible I may have also made a 'boot' partition on hda when I installed a long time ago, but can't remember for certain... <sigh>

hdb is just one 'directory' which I named 'movies'. It's seen in konqueror too, but shows nothing in it (I guess it's unmounted also, right?).




--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
Follow Ups
References