Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] Almost in a panic here...
  • From: praxis <praxis@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Sun, 16 Jul 2006 09:55:29 -0700
  • Message-id: <44BA6F81.90207@xxxxxxxxxxxxxxxxxxxxxxx>
Hash: RIPEMD160

yonaton@xxxxxxxxxxxx wrote:
> Quoting praxis <praxis@xxxxxxxxxxxxxxxxxxxxxxx>:
>> Hash: RIPEMD160
>> yonaton@xxxxxxxxxxxx wrote:
>>> Hi gang,
>>> I think I've screwed up in a major way. I use SuSE 9.3 by the way.
>>> Last night I tried to undo the manual mounting thing I'd read about on
>>> this list some time back (something with .fdi), but couldn't remember
>>> what it was, so I just deleted the .fdi file I'd created so I could get
>>> automounting back (for my DVD and DVD-Recorder). That didn't seem to
>>> make any difference, so I then went to fstab and removed the one I'd
>>> made and went back to the original. That didn't work either. So, I
>>> deleted fstab in the hopes that it would just recreate itself when I
>>> rebooted.
>>> That wasn't wise it seems. I had to start with the SuSE DVD and tried
>>> to 'repair' everything (I chose 'automatic' repair). All seemed well and
>>> I rebooted.
>>> Now, my system can't see my 'user' directories anywhere. I can log into
>>> root (obviously) but when I try to log into 'john' I get a pop-up window
>>> that reads 'Could not start kstartupconfig. Check your installation.'
>>> As root, I open konqueror to browse directories and when I click on
>>> 'home' there's nothing there.
>>> I'm really starting to get worried that I messed something up very
>>> badly, but I'm hoping that someone out there can help me figure out what
>>> to do to fix it. I'll stay on as root for now to check my mail (I have
>>> no other choice at the moment) as often as possible.
>>> Thanks to anyone and everyone willing to help me with this problem.
>>> John
>> Okay. John--
>> Let's go through this step by step. It sounds like you have a linux
>> crisis...I'll do my best to help you, and I'm sure some of the other
>> members of this list will pitch in.
>> Apparently you deleted your fstab entry. You need to ascertain where
>> your directories are, and then determine if they are intact.
>> One quick way to do this to use the "-l" facility of the fdisk command,
>> which looks like this:
>> yourhostname:/# fdisk -l /dev/hda
>> yourhostname:/# fdisk -l /dev/hdb
>> Do this, and post your results to your next email. so we can take a look
>> at them.
> Here's what I got:
> Disk /dev/hda: 81.9 GB, 81964302336 bytes
> 255 heads, 63 sectors/track, 9964 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Device Boot Start End Blocks Id System
> /dev/hda1 1 128 1028128+ 82 Linux swap /
> Solaris
> /dev/hda2 129 4045 31463302+ 83 Linux
> /dev/hda3 * 4046 4436 3140707+ 83 Linux
> /dev/hda4 4437 9964 44403660 83 Linux
> Disk /dev/hdb: 40.9 GB, 40982151168 bytes
> 255 heads, 63 sectors/track, 4982 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Device Boot Start End Blocks Id System
> /dev/hdb1 * 1 4982 40017883+ 83 Linux
> It's possible I may have also made a 'boot' partition on hda when I
> installed a long time ago, but can't remember for certain... <sigh>
> hdb is just one 'directory' which I named 'movies'. It's seen in
> konqueror too, but shows nothing in it (I guess it's unmounted also,
> right?).

Forrest replied:

Okay, John, good. now according to the fstab you posted earlier :
> I do see this also, a 'data1', but it's also empty, no /user or anything. This is also what's in my fstab:
> /dev/hda2 / reiserfs defaults 1 1
> /dev/hda1 swap swap pri=42 0 0
> /dev/hda3 /data1 auto noauto,user 0 0
> /dev/hda4 /data1 auto noauto,user 0 0
> /dev/hdb1 /data1 auto noauto,user 0 0
> devpts /dev/pts devpts mode=0620,gid=5 0 0
> proc /proc proc defaults 0 0
> usbfs /proc/bus/usb usbfs noauto 0 0

It looks like your main "/" partition is /dev/hda2, and your system is
using /dev/hda1 as swap. There are two other Linux formatted partitions
on this disk: /dev/hda3, and /dev/hda4. Also interesting from the fdisk
info you posted is that /dev/hda3, the third partition on your main
ATA/IDE hard drive, is marked "bootable" -- that might have been the
"boot" partition you were speaking of earlier. I would hazard a guess --
its only a guess --that your "home" is actually on /dev/hda4, based on
the size...but it could be either one.
Now the other disk, /dev/hdb, has only one partition, which you called
'movies'? You can't see it? Then it is unmounted. (Verify this by typing
yourhostname:/# df -h

[[..that will show you the disk partitions that are mounted right now,
in "-h" = "human-readable" format {with G notation for Gigabytes,
etc.}. IF you type just "df" it will show the results in block size

Okay, after typing that, you should verify that you do not see any of
the directories in question, /dev/hda3, /dev/hda4/ or /dev/hdb1 in the
"df -h" output.

Next step:
Experimental mounting of these directories under /mnt.
Now, John, you are going to have to test something here. Based only on
the information that you've supplied, I don't know what file system
these partitions were formatted with. You are going to have to test this
- -- the likely candidates are "reiserfs" and "ext3"...try both: [[..I'm
doing this example below for /dev/hda4, because its' the biggest
partition of the three. Similar procedure for the others..]]

yourhostname:/# mkdir /mnt/hda3; mkdir /mnt/hda4; mkdir /mnt/hdb1
yourhostname:/# mount -t reiserfs -o ro /dev/hda4 /mnt/hda4

[[..-t = type -o=read-only __good when you are testing so you can't mess
anything up__..]]

now, if the filesystem type is not reiserfs on that partition, you are
going to get an error message like this:

"mount: wrong fs type, bad option, bad superblock on /dev/hda4,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so "

so you may have to try:
yourhostname:/# mount -t ext3 -o ro /dev/hda4 /mnt/hda4
or potentially:
yourhostname:/# mount -t xfs -o ro /dev/hda4 /mnt/hda4

One of these mount commands will successfully mount the directory, as
long as the data is undamaged. Try them now and email back your
results. Once your system accepts the mount command without error, check
to see the new filesystem with "df -h"
yourhostname:/# df -h

I'll wait for your response.

- --Forrest
Version: GnuPG v1.4.4 (GNU/Linux)


Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at
Please read the FAQs: suse-linux-e-faq@xxxxxxxx

< Previous Next >